Put the 428 in last night - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 06-21-2008, 01:21 AM
Ripped's Avatar
Member
 

Last journal entry: First RoadCourse Video
Last photo:
Join Date: Jun 2005
Location: Vancouver Canada
Posts: 360
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Put the 428 in last night

Although the bodywork experts helped me a lot at the Hot rodders bulletin board, I sure like bolting stuff on a lot better than block sanding

Things went fairly well, I hope to have it fired up again mid next week, maybe.






    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-21-2008, 08:56 AM
Jmark's Avatar
Registered User
 
Last photo:
Join Date: Sep 2003
Location: phoenix
Age: 61
Posts: 4,932
Wiki Edits: 0

Thanks: 13
Thanked 47 Times in 36 Posts
Wow, looks awesome! Reminds me of back in the day when a big block Mustang would come in for a tuneup! NO ONE wanted it! A real stuff job..........but a blast to drive.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 06-22-2008, 09:19 PM
AmericanPackMule's Avatar
Registered User
 

Last journal entry: Adolessent J.R.
Last photo:
Join Date: Feb 2004
Location: Los Angeles, Calif
Age: 71
Posts: 151
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Ripped
Although the bodywork experts helped me a lot at the Hot rodders bulletin board, I sure like bolting stuff on a lot better than block sanding

Things went fairly well, I hope to have it fired up again mid next week, maybe.





----------------------------------------------------------------------

Realy Impressed!!!
My 428 ` With "2" - 550s ( Still to be Rebuilt.) Will go in my '57 Ranchero.
When I Have The Time!!! I'll Send Progress Pic's Soon...
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 06-22-2008, 09:56 PM
SSedan64's Avatar
Registered User
 
Last photo:
Join Date: Dec 2007
Location: Macon, GA.
Age: 50
Posts: 6,016
Wiki Edits: 0

Thanks: 0
Thanked 46 Times in 46 Posts
Very Nice! Looks way better at home than it did on that crate, doesn't it Ripped.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 06-23-2008, 03:46 PM
Ripped's Avatar
Member
 

Last journal entry: First RoadCourse Video
Last photo:
Join Date: Jun 2005
Location: Vancouver Canada
Posts: 360
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by SSedan64
Very Nice! Looks way better at home than it did on that crate, doesn't it Ripped.
You bet LOL

I bet it won't jump out of the car, when I rev it up either!

Got the passenger header back on yesterday, got the motor mounts to bolt up correctly, and today I hope to have it wired up after work.
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 06-23-2008, 09:43 PM
techinspector1's Avatar
Senior Curmudgeon
 
Last wiki edit: DynoSim combinations Last photo:
Join Date: Oct 2005
Location: Hemet, California, USA
Age: 72
Posts: 13,334
Wiki Edits: 326

Thanks: 844
Thanked 1,163 Times in 959 Posts
Time to fire up the hole saw and make some socket holes in the splash aprons so you can get to the plugs with the wheels/tires removed.
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 06-24-2008, 12:36 AM
Ripped's Avatar
Member
 

Last journal entry: First RoadCourse Video
Last photo:
Join Date: Jun 2005
Location: Vancouver Canada
Posts: 360
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Yes I don't know what the 'plugs will be like on this one. We had a '68 shelby gt 500 with headers, and I had to lay under the car on the ground to get some of the rear plugs.

This one has tri-y headers, maybe that will help
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 06-24-2008, 12:38 AM
SSedan64's Avatar
Registered User
 
Last photo:
Join Date: Dec 2007
Location: Macon, GA.
Age: 50
Posts: 6,016
Wiki Edits: 0

Thanks: 0
Thanked 46 Times in 46 Posts
My brother had a 71 Maverick with a 390 had to take the front wheels off to change some of the plugs.
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 06-24-2008, 07:01 AM
Arrowhead's Avatar
EFI Rules and Carbs Drool
 
Last wiki edit: The FREE T Bucket plans
Last journal entry: Sold Everything for a new project
Last photo:
Join Date: Jul 2004
Location: Stillwater, NY
Age: 50
Posts: 913
Wiki Edits: 5

Thanks: 0
Thanked 4 Times in 3 Posts
Wow, looks great. Make you take a video whene you fire it up!
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 06-28-2008, 01:34 AM
Ripped's Avatar
Member
 

Last journal entry: First RoadCourse Video
Last photo:
Join Date: Jun 2005
Location: Vancouver Canada
Posts: 360
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Fired it up tonight

No video, but I removed most of the masking tape and bubble wrap for a few pics, just to celebrate the milestone being reached

Maybe all those bleeding knuckles while block sanding the engine bay were worth it

Engine started within 2 seconds of cranking and idles nice (had to shut it down after 2 minute due to exhaust building up in the garage)
















BTW yes a lot of masking tape and protective bubble wrap went back on after the photos.

I've got lots of work to do including hiding and cleaning up the few wires on the engine block. The rest of the wiring for the chassis and engine is hidden, inside the frame or elsewhere.

I showed my daughter tonight. She thinks I should teach her to drive it (she's not a good driver at all) I told her it's a man's car, and girls aren't even allowed to ride in it LOL
Reply With Quote Quick reply to this message
  #11 (permalink)  
Old 06-28-2008, 02:36 AM
SSedan64's Avatar
Registered User
 
Last photo:
Join Date: Dec 2007
Location: Macon, GA.
Age: 50
Posts: 6,016
Wiki Edits: 0

Thanks: 0
Thanked 46 Times in 46 Posts
Kids & Stangs

Hey Ripped show your daughter this and tell her this is why. LOL!!
http://www.youtube.com/watch?v=fdbcFtVbrIo
Reply With Quote Quick reply to this message
  #12 (permalink)  
Old 06-28-2008, 09:03 AM
Ripped's Avatar
Member
 

Last journal entry: First RoadCourse Video
Last photo:
Join Date: Jun 2005
Location: Vancouver Canada
Posts: 360
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by SSedan64
Hey Ripped show your daughter this and tell her this is why. LOL!!
http://www.youtube.com/watch?v=fdbcFtVbrIo
Yeah, for real my daughter is that BAD, she absolutely thrashed the side of our PT cruiser backing it into the garage (couldn't handle the change od steering wheel operation when backing) paniced and hit the gas instead of the brake, whamo $3000 damage.

I have never even driven with her since she had her first lesson with me. I said "forget it" and called a driving school. Her personal car has a lot of road rash

...and i wasn't kidding, when I said no girls (women) are going to drive this car. There are a few women who can drive, I'm sure. I haven't met any Most of the ones I see are glued to their cell phones LOL
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine I.D. problems..... 390 or 428!? Drumtice Engine 4 06-12-2007 09:39 AM
Engine I.D. problems..... 390 or 428!? :) Drumtice Engine 2 06-12-2007 04:07 AM
Want to Know Why I Didn't Get Arrested Last Night? Ghetto Jet Off-Topic 4 10-10-2005 11:57 AM
what should I put in? Silentlion_69 Engine 4 10-22-2004 12:05 PM


All times are GMT -6. The time now is 06:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.