Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Quadrajet on stock 350 idles fine drives like junk
View Single Post
  #1 (permalink)  
Old 03-14-2010, 11:01 AM
DQ81 DQ81 is offline
Registered User
 
Last photo:
Join Date: Mar 2010
Location: NL
Posts: 147
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quadrajet on stock '78 350 idles fine drives like junk in truck

Stock 350 w/ factory Quadrajet in '78 4x4 Full Size truck.

Dual exhaust otherwise stock.

Start fine, takes a few more times turning over to start when warm.

Idles great.

If it has sat idling for 5 minutes or so. Take off WOT pull strong up to gear change into 2nd where it falls flat on it's face.

Give it a few seconds completely off the throttle I can accelerate again very shortly, falls on it's face again etc.

Can't keep a constant speed at any RPM and going up hill is a disastrous/maddening balance of feathering the throttle just to keep a MAX of 40mph, if I try WOT while driving it just about dies. Just very very very partial to no throttle keeps it alive.

Flat surface it's better but if I try and accelerate it does the same as mentioned above. The more load the worse the bog/cut out.

No backfires of any kind.

Fuel starvation?

Revs fine in Park, although haven't held it at higher RPM's for extended time to see if I can replicate the symptoms in park. Under load especially uphill its gets really really bad.

Look forward to knee-jerk reactions.

Thanks.

Last edited by DQ81; 03-14-2010 at 11:12 AM.
Reply With Quote