Radiator - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-13-2008, 09:18 AM
Registered User
 

Last journal entry: 69 Mustang
Last photo:
Join Date: Aug 2007
Location: Fort Bragg, North Carolina
Age: 40
Posts: 93
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Radiator

I went out to my garage yesterday and started up my '84 Camaro to let it run since I dont drive it often. After about 10 minutes the water in the coolant reservior started to bubble over. I went out this morning to see would it do it again and it did. I dont think that the car is overheating and the electric fan is kicking on. What can be causing this?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-13-2008, 10:30 AM
Jmark's Avatar
Registered User
 
Last photo:
Join Date: Sep 2003
Location: phoenix
Age: 61
Posts: 4,815
Wiki Edits: 0

Thanks: 0
Thanked 3 Times in 3 Posts
I would suspect that the thermostat is stuck closed.

Remove it and replace it and ck it again.

Mark
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 10-13-2008, 12:55 PM
Registered User
 
Join Date: Nov 2004
Location: California
Age: 67
Posts: 827
Wiki Edits: 0

Thanks: 27
Thanked 21 Times in 19 Posts
Or perhaps you just filled the overflow container to the top while the motor was cold. Expanding fluid/steam in the top of the radiator will push fluid out into the overflow. And the overflow will overflow. . . .
Pat
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 10-16-2008, 12:06 AM
Registered User
 

Last journal entry: 69 Mustang
Last photo:
Join Date: Aug 2007
Location: Fort Bragg, North Carolina
Age: 40
Posts: 93
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
No, it was'nt that. The overflow was actually not even half full, which is why I could'nt understand how coolant would actually back fill and overflow out of the overflow. I'm going to replace the thermostat and see what happens. Thanks for the advice.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 10-16-2008, 05:11 AM
Registered User
 
Last photo:
Join Date: Jan 2007
Location: canada
Posts: 564
Wiki Edits: 0

Thanks: 0
Thanked 3 Times in 3 Posts
blown head gasket?
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 10-19-2008, 08:52 AM
Registered User
 

Last journal entry: 69 Mustang
Last photo:
Join Date: Aug 2007
Location: Fort Bragg, North Carolina
Age: 40
Posts: 93
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I removed the thermostat and let the engine idle for about 10 minutes and water still begin to bubble in the overflow reservior. I was told that possibly the water pump is'nt circulating water through the engine which is causing this. So now I'm guessing between the water pump and a blown head gasket. When I start the car up I do see a little water coming out of the tail pipe but I'm not sure whether it's the normal condensation or water from a blown gasket. Are there any tricks out there to narrow this problem down to exactly what's wong. I'm leaning more toward the water pump because I dont feel any pressure on the hoses.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stuffing BBC into a little S10 S10 Racer Engine 6 08-06-2008 12:15 PM
Identifying water pump configuration ron2424 Engine 18 05-08-2008 12:29 PM
Radiator for my 75 V8 Vega?? fastrehotrods Engine 5 10-16-2006 11:24 PM
over heating delsman Engine 38 09-14-2005 08:32 PM
is this a usable radiator guba_unus Engine 4 07-16-2004 04:37 AM


All times are GMT -6. The time now is 08:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.