Radiator position? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 04-04-2006, 06:40 PM
"70" Cougar's Avatar
Meat-Head Extroidenaire
 
Last photo:
Join Date: Aug 2004
Location: BC Canada
Age: 32
Posts: 307
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Radiator position?

Well I want to iron out my heating issues.. runs at 230 in 10 degree (C*)
So.. my rad is placed on the engine bay side of the rad support.. is this correct or is it supposed to be on the front side of the rad support? this may give me more needed room for a fan shroud , if i ever found one . Also could anyone explain how to go about changing the heater core cause right now i just have the hose's rerouted back to the pump( not much water flow i know but desperate times call for desperate measures) and to be honest it doesn't go past 230 like it used to with it all hooked up right lol

THANKS again everyone
bill

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 04-04-2006, 06:48 PM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 62
Posts: 16,864
Wiki Edits: 5

Thanks: 20
Thanked 250 Times in 203 Posts
Get the fan shroud....dollars to donuts, thats why its overheating.

Heater core probably comes out under the dash.......
__________________
Ontario Rodders

Budget RVs
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 04-04-2006, 06:56 PM
"70" Cougar's Avatar
Meat-Head Extroidenaire
 
Last photo:
Join Date: Aug 2004
Location: BC Canada
Age: 32
Posts: 307
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Hey Poncho... well i do run a electric fan with the auto temp start/shutoff and it sure seems to pull lots of air.. (towards the motor)
Would i install the fan around or more so ontop of the electric fan.. or and if so.. i must find out if i must have the rad in front of or behind the rad support? And theres nothing really to changing the heater core... will it pi$$ out fluid in the car. Also how do i check if the heater works.. since ive had the car it hasn't worked.. but.. was totally dismantled so it may not be hooked up or something.. not sure.?

thanks
bill
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 11:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.