rear seal leak on sbc 350 - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 02-15-2005, 04:58 PM
4onthefloor 2's Avatar
1968 chevelle
 
Last photo:
Join Date: Dec 2004
Location: Bracebridge ONT Canada
Age: 50
Posts: 53
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
rear seal leak on sbc 350

hi i have a 1974 350 with rear seal leak Ive replaced 2 times and it still leaks i even off set the seal and its still leaking is there a better seal i could use for a stubborn leak like this thanks for the help ps cam plug and oil gally plugs are not leaking and rear seal only leaks when motor is running

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 02-15-2005, 05:32 PM
swvalcon's Avatar
Member
 

Last journal entry: rust on lt body shell
Last photo:
Join Date: Oct 2004
Location: mn
Age: 64
Posts: 1,014
Wiki Edits: 0

Thanks: 0
Thanked 11 Times in 11 Posts
When you said offset rear seal just what do you mean? you can buy a offset rear seal that moves where the seal runs on the crank. I've used these with good results
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 02-15-2005, 05:41 PM
302 Z28's Avatar  
Last photo:
Join Date: May 2003
Location: North Texas
Posts: 10,837
Wiki Edits: 0

Thanks: 1
Thanked 86 Times in 73 Posts
When he says offset the seal, he is refering to partially rotating the seal halves in the block and main cap. This is so the parting line of the two seal halves are not inline with the main cap/block parting line.

How many miles on this 74?

Have you checked the PCV system?

How much blowby does this engine have?

I have seen engines with excessive rear main bearing clearances that no amount of seal replacemnts could stop a leak on.

Vince
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 02-15-2005, 06:01 PM
4onthefloor 2's Avatar
1968 chevelle
 
Last photo:
Join Date: Dec 2004
Location: Bracebridge ONT Canada
Age: 50
Posts: 53
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
motor is fresh only has 6 hours on it. rear main bearing clearances are fine PCV system is working. should i try an offset rear seal or a double lip seal if so could you recommend a part number thanks Rick
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 02-15-2005, 07:13 PM
Registered User
 
Join Date: Jan 2005
Location: Tonawanda, NY
Age: 43
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Be careful it's easy to install the seal backward.It doesn't go on like it looks it should.......not that this has ever happened to me
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 02-15-2005, 08:40 PM
Mike_82's Avatar
Member
 
Last photo:
Join Date: Sep 2003
Location: Branch County, Mi.
Age: 28
Posts: 234
Wiki Edits: 0

Thanks: 2
Thanked 0 Times in 0 Posts
maybe the oil pan is bent slightly in the seal area?
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 02-16-2005, 06:23 AM
4onthefloor 2's Avatar
1968 chevelle
 
Last photo:
Join Date: Dec 2004
Location: Bracebridge ONT Canada
Age: 50
Posts: 53
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
oil pan is new its the seal.should i try an offset rear seal or a double lip seal if so could you recommend a part number has anyone tried either of these seals thanks Rick
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 02-16-2005, 07:55 AM
killerformula's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Carburetor
Last journal entry: Clean up
Last photo:
Join Date: Oct 2003
Location: Northeast
Age: 34
Posts: 3,485
Wiki Edits: 3

Thanks: 13
Thanked 27 Times in 18 Posts
I would just run it for a couple of months, how bad is it leaking? I've seen a few leak and then tighten back up later on after a few hundred miles. Almost like they're "breaking in"

K
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 02-16-2005, 03:22 PM
4onthefloor 2's Avatar
1968 chevelle
 
Last photo:
Join Date: Dec 2004
Location: Bracebridge ONT Canada
Age: 50
Posts: 53
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
car is a 4 speed and i dont want to smoke the clutch
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 03-23-2005, 03:04 PM
4onthefloor 2's Avatar
1968 chevelle
 
Last photo:
Join Date: Dec 2004
Location: Bracebridge ONT Canada
Age: 50
Posts: 53
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
found the problem guys and feel really stupid, for wasting you guys time just thought I let you know what the problem was rear back corner on driver's side rocker cover was leaking pretty good. After motor runs for 5 mins, oil would run out of lower back corner down around oil filter boss, and drip under centre of car. When I bought the Elderbrock alumium rocker covers I dropped one, and that's the corner where it hit the floor, I've since switched rocker covers from left to right and bought good gaskets, problem solved thanks guys
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 11:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.