Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Engine (http://www.hotrodders.com/forum/engine/)
-   -   Rebuilt 327 w/Edelbrock carb revs WAY too high (http://www.hotrodders.com/forum/rebuilt-327-w-edelbrock-carb-revs-way-too-high-8128.html)

CHEV66JB 05-11-2003 12:41 PM

Rebuilt 327 w/Edelbrock carb revs WAY too high
 
Hello all,

This is my first post and I'm hoping you all can help- I just finished rebuilding a 275HP 327 for my '66 Chevelle, and am trying desperately to get her back on the road. On the rebuilt motor I am running a stock intake manifold, HEI, and an Edelbrock 1406 600-CFM carb (brand new, just bought yesterday)w/electric choke.

I am new to working with carbs and timing, but thought I had everything set up correctly. Problem is, when starting the new engine, it starts but immediately goes to very high RPM's and all I can do is shut it off. I made no adjustments to the carb out of the box, simply put it on the car and tried it out.

Any help would be greatly appreciated, but PLEASE try to give suggestions in a format I can follow! Every person who has replied so far has given me instructions like I'm a 50 year old mechanic, which isn't the case 8^]

Thanks in advance,

CHEV66JB

Deuce 05-11-2003 01:12 PM

:D

OK

Have you checked for the obvious?
Disconnect the accelator linkage. Turn the idle screw out. Put a timing light on the engine and check the timimg.

IF you put a new camshaft in the 327...it needs to run a 2000PM's for about 20 minutes away :D

More later if this does not help.....

Do not get discouraged <img src="graemlins/nono.gif" border="0" alt="[nono]" /> <img src="graemlins/nono.gif" border="0" alt="[nono]" />


.

johnsongrass1 05-11-2003 01:16 PM

How high is very high RPM's. Gotta get the details in order for us to make an accurate diagnosis over the net. Many people forget the details. The more the better and the better answer you will get.

CHEV66JB 05-11-2003 01:19 PM

Hello and thanks for your reply!

I unfortunately do not have a timing light, so I am trying to work through this as best as I can (this is my first time doing a whole motor rebuild from the ground up).

When you say "turn the idle screw out", does that mean to turn it out counter-clockwise all the way?
And this is the main idle screw, not the "fast idle", correct?

Thanks again for your help.

CHEV66JB 05-11-2003 01:20 PM

I do not have specific RPM's unfortunately b/c I do not yet have my tach hooked up. I will try to get specific #'s by this evening, however it sounds like it's running well over 2000 RPM.

CHEV66JB 05-11-2003 01:25 PM

And actually, yes, the motor has a new Crane Powermax cam in it as well-

Crazy d 05-11-2003 02:30 PM

as deuce said check linkinge for tension it maybe pulling your throtle.did you plug the holes in the carb one in back carb comes with screw in plug and caps.make sure your choke is not on.lower the idle screw on the drivers sides neer where the linkage hooks on.the to screws in front with the springs are the air fuel for now screw them in all the way than open them 1 turns.if your distributor has a vacum plug it in also not sure what side one side for tranny and the other for distr.check your manual came with carb.use the correct gasket it came with carb on big hole not 4 holes.when you get it to run ok you got to rev it to 2000 for 20 min or so to break in the cam look at water and oil gages to make sure nothing goes wrong.better to have a friend there to look at engine and stuff also leaks and ect...
after you can get a timming light and tune the carb.. PS.get a tack before so you know what your reving good luck hope this helps...

CHEV66JB 05-11-2003 04:59 PM

This is my first day on this group, and already you guys have been a HUGE help. I found out it was in fact the stupid throttle linkage. When I hooked it up, I didn't even notice that it pulled the throttle back about 1.5 inches. I adjusted the linkage and after hooking up the tach, noticed all is running fine!! I only have about 80 things left to do now to drive her this summer (get it tagged, front end alignment, etc etc etc), but this was a huge accomplishment for me today. Thanks to all of you for your input!

Regards,

CHEV66JB


All times are GMT -6. The time now is 11:45 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.