Redneck Performance - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 09-02-2009, 07:36 PM
Registered User
 
Join Date: Sep 2009
Location: nebraska
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Redneck Performance Experience

Recap of Transmission purchased on eBay from RP $1,500 with shipping
FORD C4 TRANSMISSION (LOADED)- C-4 REV MAN TRANSBRAKE

I bought this transmission because I had bought a torque converter previously and had good results.

RP did not usually answer the phone when I called.
RP phone call backs were hours or a day later. Usually late afternoon.
RP closes their entire office for a week.
RP's website is has missing pictures on their web site.
The Registrant Contact for the website URL is Alan Hartmann whose email is ahartman@artcarr.com

1. The transmission that I purchased was leaking excessively after I drove it. Thereafter, it would leak once it got warmed up and I determined it was leaking from inside the bell housing.

2. As suggested by RP, I pulled the transmission and they sent me a new pump and gasket that I replaced.

3. After installing the transmission again it did not leak But, it does NOT go forward or backwards when shifted. It does go in and out of park.

4. As suggested by RP, I put washers on 1/4 inch washers on the torque convertor which was very difficult since the torque is threaded and does not have studs.

5. This washers did not make the transmission work.

6. I asked for a refund but I would have to pay shipping back and only had a 10 days to return.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 09-02-2009, 08:11 PM
S10 Racer's Avatar
http://www.warsprints.com
 

Last journal entry: W.A.R. (Wingless Auto Racing) Sprint Car Racing
Last photo:
Join Date: Nov 2007
Location: At The Dirt Tracks
Age: 55
Posts: 1,938
Wiki Edits: 0

Thanks: 4
Thanked 74 Times in 66 Posts
Quote:
Originally Posted by MachV
Recap of Transmission purchased on eBay from RP $1,500 with shipping
FORD C4 TRANSMISSION (LOADED)- C-4 REV MAN TRANSBRAKE

I bought this transmission because I had bought a torque converter previously and had good results.

RP did not usually answer the phone when I called.
RP phone call backs were hours or a day later. Usually late afternoon.
RP closes their entire office for a week.
RP's website is has missing pictures on their web site.
The Registrant Contact for the website URL is Alan Hartmann whose email is ahartman@artcarr.com

1. The transmission that I purchased was leaking excessively after I drove it. Thereafter, it would leak once it got warmed up and I determined it was leaking from inside the bell housing.

2. As suggested by RP, I pulled the transmission and they sent me a new pump and gasket that I replaced.

3. After installing the transmission again it did not leak But, it does NOT go forward or backwards when shifted. It does go in and out of park.

4. As suggested by RP, I put washers on 1/4 inch washers on the torque convertor which was very difficult since the torque is threaded and does not have studs.

5. This washers did not make the transmission work.

6. I asked for a refund but I would have to pay shipping back and only had a 10 days to return.
Sorry to hear your frustration. I bought a torque convertor and a transbrake kit from them and have had no problems but never bought a complete transmission. I had emailed them a couple of times during the install of the transbrake and had an answer the next day. I was considering exchanging my torque convertor for a smaller stall and they said they would exchange it if I paid shipping but I never did, just kept what I had. I done all this work last fall. Hmmmm.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 09-03-2009, 03:18 AM
DoubleVision's Avatar
Not Considered a Senior Member
 
Last photo:
Join Date: Oct 2002
Location: Heart Of Dixie
Age: 40
Posts: 10,658
Wiki Edits: 0

Thanks: 15
Thanked 60 Times in 57 Posts
Had it been me and I got a leaking tranny it would have went back then for them to fix. I don`t believe in the "I`ll send you the parts you can fix my screwup" deals but that`s just me. They sent you the parts for you to fix and now the tranny doesn`t work at all spells out they didn`t want the tranny back.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 09-03-2009, 03:52 AM
Thumpin455's Avatar
Ask me about Ethanol
 

Last journal entry: 65 GTO
Last photo:
Join Date: Aug 2009
Location: Michigan's U.P.
Posts: 155
Wiki Edits: 0

Thanks: 0
Thanked 4 Times in 4 Posts
When you replaced the pump did you hear anything fall inside the trans? Pull the pan and see if the struts for the bands are still in place. Also if you didnt use trans gel on the pump when you stuffed it back in you might have broken some of the seals. Park is a pawl that contacts teeth on the output shaft (more involved yes, but basically thats it) you release the pawl and the car will move, put it back in park and the pawl engages and keeps the car from moving easily. Since nothing works its pretty safe to assume you have an internal fluid leak or a broken front pump.

Would you want to fix it, send it back, or ??? If you want to fix it a C4 is one of the easiest transmissions to work with. I can get you the info you need to fix it if you want, also you can do some trouble shooting with the pages in herehttp://s189.photobucket.com/albums/z278/AuCinaoaMie/Cars%20and%20trucks/Transmissions/C4/
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 09-03-2009, 10:06 AM
ericnova72's Avatar
More for Less Racer
 
Join Date: Jan 2007
Location: S.W. Lower Michigan
Age: 48
Posts: 9,801
Wiki Edits: 0

Thanks: 48
Thanked 603 Times in 540 Posts
When you installed the new pump, you did have the trans stood up vertical with its tail facing the floor, right?? You can't do it with the trans laying down, stuff falls out of alignment when you do.

Have seen several racers in my area with Redneck Trans and converters with no reported problems.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 05:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.