Richmond PowerTrax Locker - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-06-2007, 06:22 AM
Registered User
 
Join Date: May 2006
Location: Mooresville, NC
Posts: 11
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Richmond PowerTrax Locker

I have a 68 Camaro with a 8.5in 10 bolt that I just installed a 3.90 ring and pinion with a Richmond PowerTrax No Slip locker in the carrier. The car is running a SB 350 with a turbo 350 trans, 2400rpm stall and CalTracks. I thought this would provide a better positive traction unit for good traction off the line over a standard positive trac unit. However, all I'm seeing is wheel spin on the right side - a single black mark, not dual black marks as if both wheels are pulling. If I jack up the car and turn the rear wheels, both turn in same direction as if locked. Can anyone offer any siggestions as to why only one wheel pulling? And offer advice on a better positive traction unit I could change too. Thanks!!

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-06-2007, 06:30 AM
Not A T 25's Avatar
Takes Guts To Cut One Up
 
Last photo:
Join Date: Sep 2003
Location: South Central Illinois
Age: 58
Posts: 354
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by BuddyK
I have a 68 Camaro with a 8.5in 10 bolt that I just installed a 3.90 ring and pinion with a Richmond PowerTrax No Slip locker in the carrier. The car is running a SB 350 with a turbo 350 trans, 2400rpm stall and CalTracks. I thought this would provide a better positive traction unit for good traction off the line over a standard positive trac unit. However, all I'm seeing is wheel spin on the right side - a single black mark, not dual black marks as if both wheels are pulling. If I jack up the car and turn the rear wheels, both turn in same direction as if locked. Can anyone offer any siggestions as to why only one wheel pulling? And offer advice on a better positive traction unit I could change too. Thanks!!
Did you follow the installation checks to be sure it was set up correctly? There are specific test procedures that can determine what is wrong. If you go to their web site you can get them there. Sounds like you have something installed incorrectly. I have the same unit and never have this problem the only issue I have is with the clunk when turning a corner under power which I have been told is the unit unlocking.
__________________
Success is getting what you want but happyness is liking what you get.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-06-2007, 08:41 AM
Registered User
 
Join Date: May 2006
Location: Mooresville, NC
Posts: 11
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Richmond PowerTrax Locker

I had the unit installed when the gear set was installed. I had a 4x4 driveline shop do the install, and asked if they were familiar with this unit. Owner said he had installed several before. I will look for the checklist you mentioned. I just thought maybe it was disengaging from the force at take off and not locking up. Are you saying you don't have this problem and are spinning both wheels? Thanks Again.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 08-06-2007, 09:09 AM
Not A T 25's Avatar
Takes Guts To Cut One Up
 
Last photo:
Join Date: Sep 2003
Location: South Central Illinois
Age: 58
Posts: 354
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by BuddyK
I had the unit installed when the gear set was installed. I had a 4x4 driveline shop do the install, and asked if they were familiar with this unit. Owner said he had installed several before. I will look for the checklist you mentioned. I just thought maybe it was disengaging from the force at take off and not locking up. Are you saying you don't have this problem and are spinning both wheels? Thanks Again.
Yup no problem leave double tracks it could be a dragging brake on the rear which is simulating a turn I think that would be possible.
__________________
Success is getting what you want but happyness is liking what you get.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
no-slip powertrax??? elcaminodragster Transmission - Rearend 1 05-12-2007 12:16 PM
Powertrax No Slip by Richmond BuddyK Transmission - Rearend 3 12-02-2006 01:12 PM
No slip Powertrax noise is it excessive Not A T 25 Transmission - Rearend 10 08-10-2006 10:29 AM
Powertrax locker 68 GTO Transmission - Rearend 2 06-08-2005 06:17 PM
Powertrax Locker: 1/4 mile time increase? purple1967camaro Transmission - Rearend 3 04-12-2004 07:23 PM


All times are GMT -6. The time now is 10:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.