Rough engine idle - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-19-2009, 05:58 PM
HR23TB's Avatar
Weekend Gas Hog
 
Last photo:
Join Date: May 2009
Location: South Florida
Age: 54
Posts: 4
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Rough engine idle

I was cruising around last weekend a showing off a little with a few burnouts when the lights turned green. when i came up to the last light, the engine was idleing really rough. i crippled my way on home and since then, the engin idles very rough, revving up or slowing down without any throttle work. I changed the plugs and the coil, but that didnt help. what do you think i did and how can i test it for sure?

It's a basic chevy 350 in a t-bucket, so nothing extra added on.

    Advertisement

Last edited by HR23TB; 05-19-2009 at 06:00 PM. Reason: engine info
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-19-2009, 06:10 PM
American Muscle's Avatar
305 Turbo-Fire 240hp
 
Last photo:
Join Date: Dec 2008
Location: under the hood
Age: 32
Posts: 625
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
What type of carb are you running? Could be a fuel issue. Try putting HEET(gas treament) in your gas tank and drive for a while to get it running through. This should clean out any blockage in the carb if there is any. Thats what I would do next
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 05-19-2009, 07:16 PM
HR23TB's Avatar
Weekend Gas Hog
 
Last photo:
Join Date: May 2009
Location: South Florida
Age: 54
Posts: 4
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Its an Edelbrock 650. it does sit for a while in between sunday drives. I will give it a try. I was a little worried something internal was starting to go. the engine is still realtively new, only a few thousand miles on it, but it was first started back in 1999 after a total re-build from the shortblock up.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 05-19-2009, 07:24 PM
Zimmo's Avatar
Member
 
Last photo:
Join Date: Sep 2004
Location: Ex So-Cal, now in CT
Age: 47
Posts: 158
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
If it still runs rough, put a timing light on it & see if it's moving around. Something stuck after your little WOT stink, may be the mech advance.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Distributor Tuning and Theory - Part 1 Rick WI Engine 35 04-26-2011 01:38 AM
1995 Mercury Mystique rough idle when stopped in Drive jordan2011 Engine 1 10-29-2008 03:16 PM
454 Ignition Timing Question leejoy Engine 56 09-13-2008 09:40 AM
Do I need vacuum advance? (Long Post) Chevy21 Engine 49 10-25-2007 01:51 PM
Vacuum adv.. underdog305 Engine 58 01-30-2007 12:19 PM


All times are GMT -6. The time now is 05:12 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.