Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - running no vacuum advance
View Single Post
  #11 (permalink)  
Old 02-04-2007, 01:20 PM
71C10's Avatar
71C10 71C10 is offline
U.S. Army Retired
 
Last photo:
Join Date: Sep 2005
Location: Texas
Posts: 266
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by topfuel
Just to remind everyone. Rear end gearing, camshaft specs., compression ratios, trans type don't matter as far as vacuum advance goes. Chevrolet used vacuum advance on all engines except the very hi hp models both big and small block from 140 to 454 cu.in. with rear end gearing from 2.41 to 4.56 and compression ratios from 8-1 to 10-1 with both autos and manuals.
I have always been an advocate of using vacuum advance on a street driven vehicle. If vacuum advance doesn't seem to make a difference on your combination, then maybe the combination needs more tuning and refinement. In over 27 years of working on cars and building engines, I have yet to see one street driven vehicle that couldn't be made overall more drivable with the use of vacuum advance.
I know some of you might disagree with me and that's fine. All I can say is the vehicle manufacturers spend millions on R&D and if they find they can get by without a part in a given application, they will not use it. A vacuum advance was used for a reason. Maybe some of us should consider this before we take what we have heard or read as gospel. Ok, the soap box is put away. Bring on the rebuttals.
Well said, no rebuttal here!
Reply With Quote