Rusted Plug Wire End - Hot Rod Forum : Hotrodders Bulletin Board -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 07-01-2004, 12:34 PM
k2mooch's Avatar
Last photo:
Join Date: Sep 2003
Location: Fort Mill, SC
Age: 36
Posts: 174
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Rusted Plug Wire End

'97 Mitsubishi Eclipse 2.0 4cyl
non-turbo 5 spd

The last time I had my car in the shop, they said my coil was testing under spec and would need to be replaced soon. So I waited about 4 months later and finally picked up an MSD replacement coil for it. When I took my old plug wires off the coil, I noticed that only ONE of them had a badly rusted end. The coil terminal was also rusted, as well as the spark plug terminal.

Is there something else going on that's causing this to happen to just ONE plug/wire/terminal?

I haven't replaced the wires yet but freshed up the connections and it doesn't hesitate (as much) on acceleration anymore. Sometimes it does though. Will new plugs & wires cure this, or something bigger I need to take a look into?


Reply With Quote Quick reply to this message
Sponsored Links
  #2 (permalink)  
Old 07-01-2004, 12:45 PM
Join Date: Oct 2003
Location: mn
Age: 36
Posts: 344
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
with the corrosion on there i would replace the wires and take a good look at the plugs, also on the plugs if they are carbon tracked wich is a black line on the side of the plug where the spark was jumping and a corresponding white mark in the boot I would replace both plugs and wires. but anyways plugs are cheap and wires shouldn't be to bad i would replace everything.
Reply With Quote Quick reply to this message

Recent Engine posts with photos
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 07:17 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright 1999 - 2012. All Rights Reserved.