s-10 5 speed - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 01-06-2007, 10:14 AM
runn141's Avatar
SB S10
 
Last photo:
Join Date: Sep 2006
Location:
Posts: 1,258
Wiki Edits: 0

Thanks: 20
Thanked 15 Times in 15 Posts
s-10 5 speed

is a 5 speed from a 90 model s10 with a 4.3 the same as a 5 speed from a 90 model full size chevy with a 350? if so are they the same strength?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 01-06-2007, 10:41 AM
BigMike
 
Last photo:
Join Date: Dec 2006
Location: Battle Creek, Michigan
Age: 27
Posts: 44
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
your tranny will hold up as long as you dont put the pedal to the floor and try to shift. it wont last to long like that. you should be alright to use the s10 tranny with out any problems
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 01-06-2007, 12:37 PM
OneMoreTime's Avatar
Hotrodders.com moderator
 
Last wiki edit: Health and safety in the shop or garage
Last journal entry: Yard Dog pic
Last photo:
Join Date: Jul 2004
Location: Washington State
Age: 69
Posts: 7,311
Wiki Edits: 3

Thanks: 45
Thanked 145 Times in 137 Posts
They do not show the same tag numbers in my book..would require some more investigation to determine if they are the same..should both bolt up tho..

The truck one is a Getrag unit/ not sure on the 4.3 tranny..either one would be a better choice for an S-10 swap than the one that comes with the four cyl version..

Sam
__________________
I have tried most all of it and now do what is known to work..
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 01-06-2007, 01:19 PM
Hippie's Avatar
Analog man in a digital world.
 

Last journal entry: HEI comparison.
Last photo:
Join Date: May 2003
Posts: 2,255
Wiki Edits: 0

Thanks: 3
Thanked 5 Times in 5 Posts
The 4.3 and 5.7 use the same flywheel and bellhousing bolt pattern and the '89 V-6 and V-8 C1500's both use the Getrag. The Getrag in my 4.3 '89 C1500 is the same as the 5 speed in a '96 4.3 S-10 although they changed the designation slightly and call it something else, IIRC it is now referred to as a New Process but it's still the Getrag. My friend owns a transmission shop and verified it for me becuse I was looking at a wrecked '96 S-10 for parts for the 4.3 and 5 speed for my '89 but the '96 is a "true" Vortec and my TBI wouldn't work on it without way more work than the truck is worth. I should have bought it just for the trans but didn't.............. oh well. Now a 3/4 ton fullsize may be a different story. I didn't check that.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
unusual 10 bolt GM diffy off '75 SW... paulo 1 Transmission - Rearend 2 08-16-2006 08:10 PM
s 10 willys bob cutler General Rodding Tech 6 07-29-2005 08:34 PM
Engine Vacuum is showing 10 and no higher? ataririder Engine 42 02-18-2003 07:12 PM
10 0/0 theory dinger Hotrodders' Lounge 3 09-12-2002 08:14 AM
40 ply/s 10 clip gcorbit Suspension - Brakes - Steering 0 01-28-2002 03:53 PM


All times are GMT -6. The time now is 02:41 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.