Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - s10 with gutted cat, bad mpgs.. CEL on, Limp home mode from downstream cat?
View Single Post
  #6 (permalink)  
Old 09-03-2012, 07:59 AM
T-bucket23's Avatar
T-bucket23 T-bucket23 is offline
Hotrodders.com Moderator
 
Last wiki edit: Engine basic condition - how to check Last photo:
Join Date: Aug 2005
Location: Massachusetts
Age: 57
Posts: 5,111
Wiki Edits: 26

Thanks: 7
Thanked 106 Times in 91 Posts
Quote:
Originally Posted by Dirty Biker View Post
I noticed the previous owner gutted the cat on the s10 I drive. This is a 1998 s10 with 2.2L, the mileage is horrible. The power is low. It seems to run fine though other than that. Is it possible the downstream o2 sensor is causing me to not stay in closed loop and get bad gas mileage? I have read about others using a non fouler and some steel wool to try to correct throwing the code. Any thoughts? Thanks, Austin

edit: title should read "from downstream o2 SENSOR" instead of CAT" or the like sorry. Thanks
I have seen the anti-fouler thing done, not with steel wool though. It works with a weak cat, I dont think it is going to work with one that is empty.
I also doubt the CEL on is effecting your power or mileage.
Have you scanned it to get codes, there may be several and they could shed some light. Anytime you get a vehicle that has been hacked you cant assume anything. You need to check it all.
__________________
Artificial Intelligence is no match for Natural Stupidity



Chet
Reply With Quote