s10 with gutted cat, bad mpgs.. CEL on, Limp home mode from downstream cat? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-29-2012, 05:13 PM
Dirty Biker's Avatar
Bold As Love
 
Last photo:
Join Date: Aug 2010
Location: In my van, down by the river.
Age: 38
Posts: 378
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
s10 with gutted cat, bad mpgs.. CEL on, Limp home mode from downstream cat?

I noticed the previous owner gutted the cat on the s10 I drive. This is a 1998 s10 with 2.2L, the mileage is horrible. The power is low. It seems to run fine though other than that. Is it possible the downstream o2 sensor is causing me to not stay in closed loop and get bad gas mileage? I have read about others using a non fouler and some steel wool to try to correct throwing the code. Any thoughts? Thanks, Austin

edit: title should read "from downstream o2 SENSOR" instead of CAT" or the like sorry. Thanks

    Advertisement

Last edited by Dirty Biker; 08-29-2012 at 05:25 PM. Reason: title of thread wrong
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-29-2012, 06:10 PM
Registered User
 
Last photo:
Join Date: Apr 2007
Location: Seattle, Wa
Posts: 6,713
Wiki Edits: 0

Thanks: 3
Thanked 406 Times in 351 Posts
Quote:
Originally Posted by Dirty Biker View Post
I noticed the previous owner gutted the cat on the s10 I drive. This is a 1998 s10 with 2.2L, the mileage is horrible. The power is low. It seems to run fine though other than that. Is it possible the downstream o2 sensor is causing me to not stay in closed loop and get bad gas mileage? I have read about others using a non fouler and some steel wool to try to correct throwing the code. Any thoughts? Thanks, Austin

edit: title should read "from downstream o2 SENSOR" instead of CAT" or the like sorry. Thanks
Steel wool? The down stream O2 sensor is comparing what comes out of the cat to the upstream O2 sensor measuring what's going into the cat. This is an issue of the exhaust's chemistry not one of back pressure. The O2s are looking for specific ratios of free oxygen in the exhaust stream and adjusting the mixture accordingly. In this case the computer would be reading excess oxygen which it reads as a lean mixture and is trying to compensate by throwing more fuel in.

I mean like give yourself a break, put the cat back in as it should be, a 2.2L engine isn't being held back by a catalytic converter. The O2 sensor might be toast as well. If you don't live in California you can get an aftermarket converter for a lot less than the OEM part thant will work just fine. Magnaflow and a host of others are the web let your browser do the walking.

Bogie
Reply With Quote Quick reply to this message
The Following User Says Thank You to oldbogie For This Useful Post:
Dirty Biker (08-29-2012)
  #3 (permalink)  
Old 08-29-2012, 09:57 PM
Dirty Biker's Avatar
Bold As Love
 
Last photo:
Join Date: Aug 2010
Location: In my van, down by the river.
Age: 38
Posts: 378
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
Thanks for the reply. The cat was gutted before I got the truck, it looks like it is still there only is completely hollow. I have no idea how that is even possible because running a pipe through there just makes a pipe sized hole right? I discovered this after changing the down pipe because the flexi part of it had a leak.

As for the steel wool comment, the steel wool is to be pushed into the spark plug anti-fouler and the o2 sensor screwed into that, the anti foler screwed into the pipe. I read this on some hyper miler websites.. Because several different sites suggested it, I assumed it was a known thing.

Can the downstream o2 sensor keep it from running in closed loop?

I recently replaced the battery and the check engine light came on about forty miles later..
Thanks, Austin
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 09-02-2012, 09:55 PM
curtis73's Avatar
Hates: Liver. Loves: Diesel
 
Last wiki edit: How to find cheap parts
Last journal entry: 1999-2001: Getting it on the road
Last photo:
Join Date: Dec 2005
Location: Pittsburgh, PA
Age: 40
Posts: 5,128
Wiki Edits: 16

Thanks: 0
Thanked 2 Times in 2 Posts
Quote:
Originally Posted by Dirty Biker View Post

Can the downstream o2 sensor keep it from running in closed loop?
No, but the CEL can. If the downstream O2s pick up an emissions issue, it can send it into fits and alter the fuel and timing curves to prevent emissions.

Either replace the cat (expensive) or put some o2 sims in place of the rear O2 sensor. (slightly less expensive)

Or... the equally illegal route would be to have someone reflash your PCM to ignore the downstream O2s. (slightly less expensive)
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 09-03-2012, 06:17 AM
LATECH's Avatar
Hotrodders.com Moderator
 

Last journal entry: Motor - vator
Last photo:
Join Date: Jul 2010
Location: Northeast Pennsylvania
Posts: 5,180
Wiki Edits: 0

Thanks: 199
Thanked 252 Times in 234 Posts
Never saw a downstream cat that changes A/F ratio, they are only for determining cat health. Maybe on a brand new car, but not an old S 10.
The CEL keeping the system from going into closed loop is possible, but its more dependent on the code generated and failure type than the light itself. But it DOES happen.

It sounds to me like the upstream O2 sensor is the trouble, however without knowing the exact code we cant help further the diagnosis.
You need to get the code , and if you go to autozone or something get the correct SAE number for the code. Write it down.post it here.
Last time someone came in with a scan test from autozone it had some off the wall number/listing that made no sense, and i had to scan it anyway to get the correct SAE number.It was a ford, the code number made no sense, and the code description was WAY off from anything discernable.
Its quite possible that the muffler is plugged from remnants of the cat as it most likely partly disintegrated before it was finally gutted. All the pieces would have to get caught in the muffler if anything broke loose, which does happen.
You can determine that by unbolting the exhaust at the back of the cat and then driving it to see if the power improves.
__________________
Fact is stranger than Fiction
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 09-03-2012, 07:59 AM
T-bucket23's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Engine basic condition - how to check Last photo:
Join Date: Aug 2005
Location: Massachusetts
Age: 57
Posts: 5,111
Wiki Edits: 26

Thanks: 7
Thanked 106 Times in 91 Posts
Quote:
Originally Posted by Dirty Biker View Post
I noticed the previous owner gutted the cat on the s10 I drive. This is a 1998 s10 with 2.2L, the mileage is horrible. The power is low. It seems to run fine though other than that. Is it possible the downstream o2 sensor is causing me to not stay in closed loop and get bad gas mileage? I have read about others using a non fouler and some steel wool to try to correct throwing the code. Any thoughts? Thanks, Austin

edit: title should read "from downstream o2 SENSOR" instead of CAT" or the like sorry. Thanks
I have seen the anti-fouler thing done, not with steel wool though. It works with a weak cat, I dont think it is going to work with one that is empty.
I also doubt the CEL on is effecting your power or mileage.
Have you scanned it to get codes, there may be several and they could shed some light. Anytime you get a vehicle that has been hacked you cant assume anything. You need to check it all.
__________________
Artificial Intelligence is no match for Natural Stupidity



Chet
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 09-04-2012, 05:56 AM
Registered User
 
Last photo:
Join Date: Aug 2012
Posts: 27
Wiki Edits: 0

Thanks: 0
Thanked 2 Times in 2 Posts
I have to agree with the muffler possibly being plugged up. I doubt the last owner gutted the cat, it probably just came apart. Get under the truck and bang on the muffler. If it rattles replace it.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
03 S10 4.3 cat removed - PCM does not set DTC mike 96 ws6 Modern Electronic Engines 11 02-23-2012 07:18 AM
4l60e tranny in limp mode (I think) Littlelarey Transmission - Rearend 2 01-10-2012 06:08 AM
95 Camaro 4L60e in limp home mode williampmilks Transmission - Rearend 1 12-30-2011 07:19 PM
06 Denali Limp Mode 123pugsy Transmission - Rearend 11 03-10-2010 08:17 PM
4L60E Limp Mode hardwurkindaddy Transmission - Rearend 4 11-14-2009 09:29 AM


All times are GMT -6. The time now is 04:14 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.