Saginaw Transmission Problem - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-30-2006, 12:20 PM
Registered User
 
Join Date: Aug 2006
Location: ROCHESTER,NY
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Saginaw Transmission Problem

I recently purchased a rebuilt Saginaw four speed tranny. For some reason, I have tranny fluid dripping onto my floor apparently coming from the connection between the speedometer cable and the speedometer. The only reason I can think of is the lack of a vent in this tranny, which I discovered. If that is the case, what can I do short of changing tail shafts with one that has a vent? Has anybody had this problem or know a solution?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-30-2006, 01:32 PM
johnsongrass1's Avatar
Race it, Don't rice it!
 
Last photo:
Join Date: Jul 2002
Location: Columbia, Mo
Age: 37
Posts: 4,062
Wiki Edits: 0

Thanks: 0
Thanked 8 Times in 8 Posts
I drilled a 3/32 hole in th top of mine.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-30-2006, 02:19 PM
rj57's Avatar
Member
 
Last photo:
Join Date: Aug 2004
Location: OH
Posts: 344
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
If you have gear lube leaking from where the speedometer drive gear slides into the transmission, then the drive gear must be worn. They spin at quite a few revolutions during the time you use the transmission.

And there's also a rubber O-ring that goes around the slip in collar for the speedo drive gear. If your transmission is missing this O-ring you will get gear lube leaking out of there.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 08-30-2006, 08:34 PM
Registered User
 
Join Date: Aug 2006
Location: ROCHESTER,NY
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
saginaw tranny problem reply

Thanks for the answer; but not leaking at the tranny, but under the dash board at the speedometer.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 08-30-2006, 10:29 PM
Member
 
Last photo:
Join Date: May 2003
Location: Shreveport LA
Age: 64
Posts: 5,103
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
There's also a seal in the outer end of the "bullet" where the driven gear comes out to meet the cable end. I will confess to having had the problem with a Saginaw 3-speed many years ago, but I don't remember actually fixing it, except that when I swapped it for a Muncie 4-speed, it didn't do it any more.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
blower idle rpm problem Ratoflic Engine 7 12-01-2008 03:31 AM
350 transmission reinstall front pump problem.... BigDawgsEatFirst Introduce Yourself 3 08-28-2004 12:03 PM
can a leak on the intake manifold cause problem when my transmission shifts dopey Transmission - Rearend 7 08-01-2004 09:43 AM
transmission problem turbo 350 jester429 Transmission - Rearend 1 10-04-2003 07:34 PM
transmission problem smallz Transmission - Rearend 5 05-31-2003 10:47 AM


All times are GMT -6. The time now is 03:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.