Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Garage - Tools (http://www.hotrodders.com/forum/garage-tools/)
-   -   Sand blaster issues (http://www.hotrodders.com/forum/sand-blaster-issues-228341.html)

chief36chevy 01-13-2013 01:19 PM

Sand blaster issues
 
Ok I have a pressure type sand blaster. I have found that you need three things to keep it working.
1 dry sand, 2 dry air, and sifted sand.
I bought a few bags of Black Diamond 20-40 grit. When I went to screen/sift it I found that about half the sand would not go through the screen. I donít want to throw this away, so I thought that I could grind it some how. Has anyone run into this situation and if so any thoughts on how to grind it down to a usable grit?

buicfrank 01-13-2013 01:32 PM

problem with blaster
 
Have you tried running some through the unit? Could be it just needs cut down some before it will go thru the screen. Frank

chief36chevy 01-13-2013 08:04 PM

I have tried this in the past but it clogged up my nozzle quite a bit.
That is why I switched to sifting the sand first.

NEW INTERIORS 01-13-2013 08:27 PM

I only use Play sand in mine...Still have to run it through the screen/sift.. But I only get about 20 little peices that don't go through..I find it's the best thing to use..

carolinacustoms 01-13-2013 09:38 PM

Have you tried to change the nozzle/tip on the blaster? My blaster has several size tips for different size media. Also is it clogging when you are using it or just when you first open the valve? I ask because mine will clog when you open the valve at the bottom of the tank if you don't open the valve at the tip first so the sand can keep moving through the hose when pressurized. I guess it just slams it all in the tip and clogs. Just a thought.

Kelly

chief36chevy 01-14-2013 05:53 PM

It would clog while using it. When I would remove the nozzle I would find a piece of media stuck in the nozzle. That is what prompted me to start screening my media.
I will try to break it up in my blast cabinet with a bigger nozzle tomorrow. Wish me luck.

carolinacustoms 01-14-2013 05:55 PM

Quote:

Originally Posted by chief36chevy (Post 1634868)
It would clog while using it. When I would remove the nozzle I would find a piece of media stuck in the nozzle. That is what prompted me to start screening my media.
I will try to break it up in my blast cabinet with a bigger nozzle tomorrow. Wish me luck.

I wish you all the best. You may be able to find a bigger nozzle for your other blaster as well.

M5StudeGuy 02-10-2013 08:39 PM

what are you using to sift your media with. I use a window screen from a normal household window.
I have no issues to this point

cruizin uncle bob 02-11-2013 05:59 AM

Don't think grinding your sand is worth the time or effort, I do filter my sand through a screen, check with your local monument place, those guys that blast the marble for headstones, I have bought really good blasting sand from them and also bought a great heavy duty nozzle from them to replace mine as it was a cheapie that wore through really quick. Good luck.


All times are GMT -6. The time now is 10:24 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.