SB 400 water pump HELP - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-07-2004, 05:11 PM
Registered User
 
Join Date: Oct 2004
Location: NC
Age: 42
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
SB 400 water pump HELP

ok here it is..

i have a 1976 pontiac trans-am 400 i got it a few months ago and never ran the engine more than a few minutes to move it around the yard or whatever.. I recently completed the restoration to the extent of making the car road worthy and i am now trying to make it reliable.

I noticed that after 10 minutes or so the engine overheats.. So, i pull the thermostat and check for flow.. Not a whole lot of water flow.. So today i ran down to car-quest and picked up a water pump.. When i disassembled the water pump i simply removed the from plate, which had the impeller on the back. inside the pump body on the timing gear cover side, There are 2 1inch holes with tubular collars that go into the block.. I have never seen anything like that so i talked to a mechanic friend up the street, he said there is supposed to be some sort of "plate" that goes between the front of the pump housing and lines up on the 2 holes that go into the timing chain cover" .. I am guessing that would also have a recess for the impeller . Right now there is no "flow" of water it only circulates minimally when the water heats up.

Anyways.. If anyone knows what that plate is called, and if you could point me in the right direction of obtaining one, i'd really appriciate it.. I have stumped the guys at comaroland, and all the local parts stores..
Thanks

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-08-2004, 06:08 AM
Registered User
 
Join Date: Oct 2004
Location: NC
Age: 42
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
really need some help. anyone?
Thanks
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 10-08-2004, 12:22 PM
BanditT/A's Avatar
Member
 
Last photo:
Join Date: Sep 2003
Location: Manchester, NH
Posts: 270
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Hey there,
I know exactually what you mean. Without this plate the motor will heat up very quick and overheat. Trust me, I too ran into this same problem. That little plate guides the water water flow through those two little sleaves that go to the block. Without one of these plates, the water has no direction and therefore doesn't get pumped through the motor well enough too cool it properly.

You need one of these:
http://cgi.ebay.com/ebaymotors/ws/eB...category=33604
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 10-08-2004, 03:44 PM
Registered User
 
Join Date: Oct 2004
Location: NC
Age: 42
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
pat yourself on the back my friend.. Thank you very much!!!!!!!!
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 10-08-2004, 06:16 PM
BanditT/A's Avatar
Member
 
Last photo:
Join Date: Sep 2003
Location: Manchester, NH
Posts: 270
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
No problem. Always willing to help out as fellow rodder. Good luck with your motor.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 06:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.