SBC 305 Problems HELP! - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 04-28-2009, 10:55 PM
Registered User
 
Join Date: Apr 2009
Location: Detroit
Posts: 11
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
SBC 305 Problems HELP!

Recently I had purchased a 1985 Camaro IROC Z from a guy. The car has been sitting for quite a while, If I had to guess I would say > 3 years.

So I get the car home and start working on it right away. Clean the Throttle and moveable parts and lubricate. Got a new battery and sprayed a few sprays of starter fluid in the Holly 750 quadra jet. Starts up and sounds good from the back. But I noticed a "Tink" sound coming from the left of the engine. While looking at it from the nose of the car. It is barely even noticeable unless I get on the engine a little bit then it "tinks" faster when the engine revs up. I pulled off the valve covers and it seems like all of the lifters are moving just fine.

I was recomended to do an oil change and add some "gunk remover" before the oil change and run for 5 minutes to clean the engine a little bit from sitting. I do so, than proceed to do my oil change. I add Castrol GTX and some of the Lucas Oil treatment (also recommended) to clean and lubricate whatever was left hoping it was a stuck rocker arm or something of that sort hoping the new oil and an idle while the engine running for about a half an hour would maybe "un stick" the rocker arm or whatever it is making this sound.

What I am asking is, What should I do next to diagnose the problem? I am stuck and would love to have this project running with in the next month. I figure you experts would be great to ask this question to!

please help!

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 04-29-2009, 03:43 AM
DoubleVision's Avatar
Not Considered a Senior Member
 
Last photo:
Join Date: Oct 2002
Location: Heart Of Dixie
Age: 40
Posts: 10,657
Wiki Edits: 0

Thanks: 15
Thanked 60 Times in 57 Posts
Check for exhaust manifold leaks. Most camaro`s I rode in all were prone to this problem.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 04-29-2009, 11:25 AM
Registered User
 
Join Date: Jun 2008
Location: Michigan
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
It could be as simple as a loose spark plug too. That can sound bad but is easy to fix!!

Mike
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 04-29-2009, 01:16 PM
80's rule!'s Avatar
Registered User
 
Join Date: Dec 2008
Location: Tennessee
Posts: 47
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Is it a tink or a tick, I have a 87 z-28 that did the same thing. Turns out if you look at the vacuum lines that run into the emissions that run into the carb you'll find a little module that ticks like crazy. Drove me nuts till I found it. Listen to what i'm saying and listen somewhere right between the maf sensor and the carb. Left side as you desribe. Also for the record NEVER put a gunk remover in your oil and try to shake up old gunk. I did that also and guess what, it shook some gunk off and left pieces of gunk in my oil pump screen and the next thing that happened I lost oil pressure due to this. Clogged everything up in the screen. And if you think you can just drop the pan on a Camaro of that year and swap it out, it's a joke. You have to lift the motor to drop the pan on a 305 to get to the oil screen. It's a nightmare.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 04-29-2009, 05:34 PM
Registered User
 
Join Date: Apr 2009
Location: Detroit
Posts: 11
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Thanks, for the replies. It's not the exhaust manifold, but good looking out b/c I think I need to fix that.

All of the spark plugs seem to be fine, plugged in and working alright!

The sound is definitely a TINK' sound, it's almost a type of racket. Metal on Metal for sure, and it revs about parallel to the engine RPMs. It isnt terribly loud until the engine revs up higher around 4000rpm, than the noise level gets a little up there.

I am still very unsure on what to check next? What would a rocker arm sound like? How would I be able to verify that sound or even check it physically without using a cherry picker. I am w/o a garage and have very limited tools but I am adamant about getting this old thing going again! It's got a lot of character and could really be a great automobile!

Thanks guys, once again
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
SBC 305 Heads on a 350 ???? Brawler Engine 8 01-06-2009 10:48 PM
350 SBC doesn't idle, other problems too. ajax1 Engine 17 02-25-2008 08:33 PM
What to set timing at? SBC 305 / CS274 hon_jr Engine 19 10-23-2007 06:06 PM
305 SBC advice rambler220 Engine 19 02-22-2007 12:40 PM
305 heads on a 400 sbc boomerac11 Engine 16 09-03-2003 09:22 PM


All times are GMT -6. The time now is 06:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.