sbc 350 popping out exhaust through out rpms - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-09-2011, 09:02 PM
prettyboyced's Avatar
Registered User
 
Join Date: Sep 2009
Location: houston tx
Age: 23
Posts: 181
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
sbc 350 popping out exhaust through out rpms

i have a vortec 350 xe 274 long tube headers street hire ignition box auto lite 605 plugs gap at .045 accel wires 600 1405 edelbrock car primary .104 .070x.042 sec.110 from 2K and up it pops out the exhaust but not real bad timing set at 18 initial and 32 total

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-10-2011, 01:17 AM
prettyboyced's Avatar
Registered User
 
Join Date: Sep 2009
Location: houston tx
Age: 23
Posts: 181
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
And If I hold it a at certain rpm you can feel it popping could this be a lean misfire
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-10-2011, 02:25 AM
B.A.M.F
 
Last photo:
Join Date: Feb 2010
Location: New York
Age: 27
Posts: 252
Wiki Edits: 0

Thanks: 2
Thanked 0 Times in 0 Posts
could be a serious exhaust leak at the manifold flange, in my race car i had an issue similar to this with open full length headers major diff was the fuel vapors in the tubes would catch fire this happened because the bolts holding the headers up were walking out
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 07-10-2011, 07:33 AM
GMC boogie's Avatar
Member
 
Last photo:
Join Date: Nov 2004
Location: Louisiana
Age: 49
Posts: 637
Wiki Edits: 0

Thanks: 1
Thanked 22 Times in 22 Posts
Sounds ignition related, I would start with the Accel wires, never had much luck with thier stuff.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 07-10-2011, 11:41 AM
prettyboyced's Avatar
Registered User
 
Join Date: Sep 2009
Location: houston tx
Age: 23
Posts: 181
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
I put locktite on the collector bolts and tighten them with an impact so they on there pretty good I was thinking I'm running lean on the primaries because at wot it's runs great with no popping
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 07-10-2011, 11:51 AM
dklong's Avatar
Member
 
Last photo:
Join Date: May 2002
Location: sussex nb canada
Age: 49
Posts: 250
Wiki Edits: 0

Thanks: 0
Thanked 2 Times in 2 Posts
I'm the same as gmc boogie. never had good luck with accel ignition stuff, also run AC - DELCO plugs in a Chevy
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 07-10-2011, 12:18 PM
cool rockin daddy's Avatar
1.21 giga-watts???!!!!
 
Join Date: Aug 2003
Location: wherever cool cars are
Posts: 1,535
Wiki Edits: 0

Thanks: 0
Thanked 3 Times in 3 Posts
Why is your total timing so low? Only 32 degrees?
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 07-10-2011, 12:40 PM
prettyboyced's Avatar
Registered User
 
Join Date: Sep 2009
Location: houston tx
Age: 23
Posts: 181
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
Vortec heads
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 07-14-2011, 07:10 PM
prettyboyced's Avatar
Registered User
 
Join Date: Sep 2009
Location: houston tx
Age: 23
Posts: 181
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
Could this be a fuel problem because it only happen at cruise which only on the primaries and doesn't happen on wot
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 07-14-2011, 07:38 PM
bigdog7373's Avatar
Of course it's fast
 
Last photo:
Join Date: May 2010
Location: florida
Posts: 2,670
Wiki Edits: 0

Thanks: 13
Thanked 49 Times in 49 Posts
I would've said timing too advanced. But 32* isnt much. What's your compression?
Reply With Quote Quick reply to this message
  #11 (permalink)  
Old 07-14-2011, 07:54 PM
prettyboyced's Avatar
Registered User
 
Join Date: Sep 2009
Location: houston tx
Age: 23
Posts: 181
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
9.7:1 and I tried playing with timing and if it was an exhaust would it pop on WOT
Reply With Quote Quick reply to this message
  #12 (permalink)  
Old 07-14-2011, 08:06 PM
bigdog7373's Avatar
Of course it's fast
 
Last photo:
Join Date: May 2010
Location: florida
Posts: 2,670
Wiki Edits: 0

Thanks: 13
Thanked 49 Times in 49 Posts
Could be a overly rich mixture. Not burning completely, and combusting in the headers.

Last edited by bigdog7373; 07-14-2011 at 08:12 PM.
Reply With Quote Quick reply to this message
  #13 (permalink)  
Old 07-14-2011, 08:11 PM
prettyboyced's Avatar
Registered User
 
Join Date: Sep 2009
Location: houston tx
Age: 23
Posts: 181
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
That's could be y it doesn't pop when I'm at wot
Reply With Quote Quick reply to this message
  #14 (permalink)  
Old 07-14-2011, 11:59 PM
cool rockin daddy's Avatar
1.21 giga-watts???!!!!
 
Join Date: Aug 2003
Location: wherever cool cars are
Posts: 1,535
Wiki Edits: 0

Thanks: 0
Thanked 3 Times in 3 Posts
Again, why such low timing?
Reply With Quote Quick reply to this message
  #15 (permalink)  
Old 07-15-2011, 02:06 AM
DoubleVision's Avatar
Not Considered a Senior Member
 
Last photo:
Join Date: Oct 2002
Location: Heart Of Dixie
Age: 40
Posts: 10,657
Wiki Edits: 0

Thanks: 15
Thanked 60 Times in 57 Posts
By all means, get the timing on spec, it`s not going to run right until you do.
Next is there could be some crossed spark plug wires, very common occurance. If everything checks out okay and you get the timing in spec and the problem persists, pop the valve covers and fire it up, at idle look for a rocker arm or several rocker arms that aren`t doing anything, if you find such, then you have a bum cam.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
popping out the exhaust Sagacious Engine 13 12-02-2006 07:28 AM
popping out the exhaust mkclat Engine 9 08-28-2006 10:35 AM
popping in exhaust DS1784 Engine 7 03-16-2005 01:20 PM
exhaust popping dubie Engine 22 07-02-2004 05:41 PM
Pontiac 406 popping above 4000 RPMs HotRodF100 Engine 10 04-22-2002 12:13 AM


All times are GMT -6. The time now is 12:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.