SBC camshaft running in - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-08-2010, 01:01 AM
theg's Avatar
Registered User
 
Last photo:
Join Date: Nov 2010
Location: australia
Posts: 62
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
SBC camshaft running in

Any tips for first time start up of a new solid roller cam and valvetrain . Thanks all

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-08-2010, 01:15 AM
Registered User
 
Last photo:
Join Date: Mar 2009
Location: Burton, MI
Posts: 781
Wiki Edits: 0

Thanks: 34
Thanked 15 Times in 14 Posts
Roller cam's have no 'run-in' like a flat lifter.

Basically just fire it up and drive it. generally avoid driving a steady speed or full throttle use for the first few miles.. but give it some throttle as you need a bit of cylinder pressure to seat the rings.
change the oil and filter after 50 miles and give 'er hell.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 11-08-2010, 01:20 AM
theg's Avatar
Registered User
 
Last photo:
Join Date: Nov 2010
Location: australia
Posts: 62
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I see . That explains why 1/2 hours searching the net I couldnt find anything on running in rollers but plenty on flat tappets .
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 11-08-2010, 01:22 AM
Registered User
 
Last photo:
Join Date: Mar 2009
Location: Burton, MI
Posts: 781
Wiki Edits: 0

Thanks: 34
Thanked 15 Times in 14 Posts
no problem.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
SBC Running HOt Fiasco Engine 9 08-09-2010 05:04 PM
SBC 350 suddenly started running horrible 350cruiser Engine 10 06-27-2009 10:15 PM
Anybody running a 377 SBC????? xntrik Engine 5 01-23-2007 07:53 AM
camshaft degreeing sbc chevrolet_dragracer Engine 4 03-29-2006 05:17 AM


All times are GMT -6. The time now is 03:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.