sbc dist. problem - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 12-31-2012, 04:45 PM
Registered User
 
Join Date: Oct 2012
Posts: 15
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
sbc dist. problem

I just got a performance hei, really cheap, 38 plus shipping. its new not rebuilt. I droped it in, and it sits about 1/8 above the manifold. I thought it needed to go in the oil pump, but that was not the case. It,s in the pump, when it,s not in the pump it sitsmore than 3/8 high. it drops in the pump and does not bottom aginst the manifold it sits on the center drive shaft. If I tighten it it will be in a bind on the shaft. the shaft seems to long, is this possible ? What can I do? What can I check? Is the cheap part suffering from poor qualty controll? Is it junk? I am pissed. Or am I missing somthing? HELP! As always THANKS for your help.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 12-31-2012, 05:53 PM
Richiehd's Avatar
JS-70
 
Last photo:
Join Date: Jun 2011
Location: Jupiter FL
Posts: 854
Wiki Edits: 0

Thanks: 166
Thanked 58 Times in 51 Posts
Something not right, Check the length against a stock one or the one you took out. I have had it where you needed a shim or 2 but 1/8th inch seems a bit much. I always check the depth WITHOUT the gasket and make sure there is a little room, so as not to bind the pump, then install gasket. I had one of those Chineses performance distrbuters in my Speed Skiff, it didnt last long.

I think those shims are available at Summit or Jegs
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 12-31-2012, 07:57 PM
RWENUTS's Avatar
Registered User
 
Last photo:
Join Date: Nov 2011
Location: Nanaimo, BC, Canada
Age: 63
Posts: 2,011
Wiki Edits: 0

Thanks: 60
Thanked 214 Times in 202 Posts
Sometimes the tang that fits into the oil pump slot is a hair to big. Grind it or file a bit off. Go slow, test fit several times if needed.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 01-01-2013, 01:43 AM
cobalt327's Avatar
WFO
 
Last wiki edit: Intake manifold
Last journal entry: 1980 Malibu Wagon
Last photo:
Join Date: Mar 2009
Location: Atlanta
Age: 59
Posts: 5,037
Wiki Edits: 1616

Thanks: 128
Thanked 597 Times in 546 Posts
Quote:
Originally Posted by TNCHEVYMAN View Post
I just got a performance hei, really cheap, 38 plus shipping. its new not rebuilt. I droped it in, and it sits about 1/8 above the manifold. I thought it needed to go in the oil pump, but that was not the case. It,s in the pump, when it,s not in the pump it sitsmore than 3/8 high. it drops in the pump and does not bottom aginst the manifold it sits on the center drive shaft. If I tighten it it will be in a bind on the shaft. the shaft seems to long, is this possible ? What can I do? What can I check? Is the cheap part suffering from poor qualty controll? Is it junk? I am pissed. Or am I missing somthing? HELP! As always THANKS for your help.
If there's a plastic collar on the bottom of the pump drive shaft like used stock, sometimes the collar will get pulled up out of position when the distributor is removed. It can be pushed back into place w/a long screwdriver, etc. if this has happened. It's better to use a drive shaft that has a steel collar.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
SBC Dist. will not line up? will it ever end? chucksrt Engine 28 05-01-2012 04:38 PM
Weird dist. problem,please help SBCFREAK Electrical 3 12-05-2008 08:54 AM
What do i need to get going sbc dist. Chevy Hi-Po Electrical 1 02-19-2006 09:53 PM
94 chevy truck maybe dist./ignition problem,please help! bluesmanjesse Engine 14 11-19-2004 03:31 PM
problem with dist. rotor onecoomofo Engine 3 05-22-2004 07:15 PM


All times are GMT -6. The time now is 04:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.