sbc high torque starter - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 03-11-2010, 10:22 PM
cutthroatkid's Avatar
two cups of tea
 
Last wiki edit: Need more horsepower for my 305 Last photo:
Join Date: Jun 2009
Location: st.louis mo
Posts: 919
Wiki Edits: 2

Thanks: 17
Thanked 2 Times in 2 Posts
sbc high torque starter

I posted this in electrical&didn't get much help,I recently put in a high torque starter&the other and I noticed when I would turn the car off the starter would go click click click...even when the cars not hot what could be causing this?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 03-16-2010, 09:15 AM
richard stewart 3rd's Avatar
Registered User
 

Last journal entry: 351W rebuild
Last photo:
Join Date: Jan 2006
Location: tremont, pa.
Age: 69
Posts: 2,217
Wiki Edits: 0

Thanks: 13
Thanked 15 Times in 14 Posts
Hi Kid,
Is this what your saying?

I recently put a high torque starter on my engine & the other day I noticed that when I turn the car off, & then try to restart it, the solenoid goes click, click, click, & the starter doesn't spin even if the engine isn't hot, what could be causing this?

Battery fully charged? clean battery connections, check & clean grounds, change the solenoid, check the brushes in the starter, have the starter checked at the auto parts store.
Rich

Last edited by richard stewart 3rd; 03-16-2010 at 09:30 AM.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 03-16-2010, 09:50 AM
How fast is fast enough?
 
Last photo:
Join Date: Jun 2005
Location: St. Louis, MO
Age: 28
Posts: 8,666
Wiki Edits: 0

Thanks: 16
Thanked 277 Times in 259 Posts
If everything else is fine, which I would presume if it worked until this point then it sounds like you have a bad starter. Could be a short too. What starter are you using?
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 03-16-2010, 10:26 AM
Notlad1's Avatar
Don
 
Last photo:
Join Date: Sep 2007
Location: Austin,Tx
Age: 76
Posts: 20
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Check your engine to chassis ground.


Don
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 03-16-2010, 12:54 PM
cutthroatkid's Avatar
two cups of tea
 
Last wiki edit: Need more horsepower for my 305 Last photo:
Join Date: Jun 2009
Location: st.louis mo
Posts: 919
Wiki Edits: 2

Thanks: 17
Thanked 2 Times in 2 Posts
Ill check everything before long&let you guys know,I broke a few toes so I'm kinda out of commision
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 03-16-2010, 01:05 PM
Rickracer's Avatar
ASE Master Tech, Fabricator
 
Last wiki edit: Taurus 2-speed fan control wiring diagram Last photo:
Join Date: Jan 2010
Location: Kissimmee, Florida
Age: 55
Posts: 936
Wiki Edits: 8

Thanks: 0
Thanked 3 Times in 3 Posts
If the starter is clicking, as in trying to start, or something similar, you must be leaving out some details. Like how long does it keep doing this? I would take a test light, and check the terminals on the starter to see if any of them are getting juice when the shouldn't be. The only one that should be hot is the main terminal where the hot from the battery attaches.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
400 sbc starter problems, Cracked Block. Adapter kit needed? tiresmoke55 Engine 7 04-16-2011 03:28 AM
SBC Starter and flywheel problems WakBordr7387 Engine 18 03-05-2011 02:13 AM
SBC starter problems punk1c5040 Engine 26 12-28-2008 07:58 AM
New High Torque Starter Connection prob . tony72 Engine 2 12-30-2007 06:24 AM
Building a SBC to rev to 8k, and have power Andyrew Engine 52 04-17-2006 12:46 PM


All times are GMT -6. The time now is 06:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.