Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - SBC HVP oil pump, low pressure
View Single Post
  #6 (permalink)  
Old 01-09-2009, 04:15 PM
tnsmith10's Avatar
tnsmith10 tnsmith10 is offline
when will it rain???
 
Last photo:
Join Date: Jul 2003
Location: where its very dry and dusty
Age: 43
Posts: 1,297
Wiki Edits: 0

Thanks: 0
Thanked 2 Times in 2 Posts
im still getting pressure rise on engine revs, but mayb e only about 10 psi. the car came with a 307 and the distributor is straight out of that engine which is an hei i slapped in a few years ago to get rid of the old points style it origonally came with. and the 307 had good oil psi. 55 cold and 25-30 hot idling. the only thing different is the arp pump shaft that i bought at a local performance shop.
the sender is in the same spot as the 307 next to the distributor. the engines bottom end is completely rebuilt, and i trust the man (ive known him for years and is quite competent at engine machine work and building), who not only did the machine work (.040 over), but assembled the short block as well. the engine was given to me when the shop changed hands from being an auto machine shop to a transmission shop and the owner was clearing out the leftover engine parts and all to make room for all the equipment and all needed to run a proficient transmission shop.
so at least at this point you all can understand why the oil pump i had obtained is questionable. it belonged to someone else i knew and not that i didnt trust him, but i still opened it up and checked to make sure all was ok, which from what i could tell did. the only thing i didnt check out was the regulator for psi. im sure this is the issue, but i know there are others out there who have more info and knowledge of oil pumps than i do which is why i brought this up... thx for all the info and help.
Reply With Quote