Scat cranks? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-09-2004, 09:16 PM
Member
 
Join Date: Aug 2003
Location: NC
Age: 36
Posts: 148
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Scat cranks?

Im just posting to see what people think that have run these cranks... Any problems etc? what kind of RPM were you turning?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-09-2004, 09:18 PM
Member
 
Join Date: Nov 2002
Location: Bakersfield
Posts: 143
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Having good luck so far, shift at 6800 has gone to 7500 on accident a few times. My machinists said that scat cranks overall are good cranks just some are harder to balance than others.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 05-09-2004, 09:26 PM
mstngjoe's Avatar
Member
 
Last photo:
Join Date: Jan 2003
Location: Oregon
Age: 63
Posts: 593
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
http://hotrodders.com/search.php?s=&...der=descending
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 05-10-2004, 12:04 AM
Sandflea427SS's Avatar
Anything with a throttle
 
Last photo:
Join Date: Apr 2003
Location: South Central Pa
Posts: 440
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
6,000-6500 RPM.....Great cranks....I've only used the 9000 series though.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 05-10-2004, 08:18 PM
lonewolf3197's Avatar
Chief Petty Officer, USN
 

Last journal entry: My Monte Carlo
Last photo:
Join Date: Dec 2003
Location: Chesapeake, Va
Posts: 77
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I'm running one in my 94 Camaro. LT-1 Stroker and I consistantly shift at 7200 rpm and haven't broken it yet. Make sure you use a realy good assembly lube like royal purple when putting it together. I had to take mine back apart after 6000 miles due to low oil pressure turns out the cranke was scored. I had a friend tell me to use a better lube on the scat cranks when installing them and to baby em until they are good and broke in.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 04:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.