Secondary spring question - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 12-01-2007, 11:27 PM
Getting distracted at work...
 
Last photo:
Join Date: Mar 2007
Location: California
Posts: 120
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Secondary spring question

When I stomp on my throttle, my engine bogs; almost shuts off. I read in a magazine where a guy wrote in with the same stuff I had (a C-3 with a Demon carb) and was having the same problem. The magazine said its the secondary springs in the carb. I got the spring kit the group of different springs, and I can't remember what the mag said about the stiffness and the secondary opening. The chart that came with the springs makes it seem that the soft the spring, the sooner the secondaries will open. But I "thought" I remembered it being the need for a stiffer spring that was causing the problem. Someone please set me straight...

Hammer

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 12-01-2007, 11:34 PM
Registered User
 
Last photo:
Join Date: Apr 2007
Location: texas
Posts: 119
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
you talking about vacuum secondary? a stiffer spring will open the secondaries slower and a softer spring will open them faster. if it bogs real bad off the line try a step or two stiffer, but you may have a prob with accel pump size and shot size, just keep playing but only make one small change at a time, and maybe document the changes and how it ran. to see what you like the best. good luck.


learning carbs is a whole lot easier than learning women, thats why men love cars.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 12-01-2007, 11:40 PM
Getting distracted at work...
 
Last photo:
Join Date: Mar 2007
Location: California
Posts: 120
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
It not bogging from too much gas... When I stomp on it, its almost like the engine dies for a second, then...takes off. The mag said it was from the butterflies opening faster than the secondaries were shooting gas. So the delay was from a big pocket of air..Know what I'm sayin?

Hammer
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 12-02-2007, 01:06 AM
Registered User
 
Join Date: Jun 2007
Location: plano texas
Posts: 374
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
bog

I think is your pump arm. The spring will not cause a bog that bad. It will just seem sluggish till 3000 rpm. Lightest (open sooner) yellow, purple, plain (standard Holley) black (will probably not open all the way). Try the black if that helps you know that is it. If that does not help try the pump arm spring tighten it one turn try then keep going. If it backfires then loosen. It should be preloaded to just touching depending on your setup Ie high stall. Might check your timing as long as the hood is up.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
A- body spring question gilliganspl Suspension - Brakes - Steering 2 03-11-2007 10:44 PM
Spring clamp question. HemmiGremmie Suspension - Brakes - Steering 2 05-10-2006 05:56 AM
Leaf Spring Question 39chevy Suspension - Brakes - Steering 2 11-19-2003 06:35 AM
front end popping maddmaxx Suspension - Brakes - Steering 4 11-15-2003 09:24 PM
secondary spring 69 chevelle SS Engine 2 09-11-2003 06:50 PM


All times are GMT -6. The time now is 04:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.