serpentine belt & water pump belt - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 12-19-2012, 04:50 AM
Registered User
 
Join Date: Dec 2012
Posts: 6
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
serpentine belt & water pump belt

It sounds like my serpentine belt is making a chirping sound(second guess is its the water pump belt) & a mechanic said not to worry about it but I am worried because this 93 Topaz is my only transportation.I know its nothing that will leave me stranded on the side of the road but what do you think?To change the two belts plus labor will cost about 100 unless the pully has to be re-placed(which I doubt because it was re-placed along with the serpentine belt about 3 yrs. ago.)It really sounds as though the sound is coming from the serpentine belt but it just makes the sound when its cold.After it warms up then it cannot be heard.I waxed my car & touched up every scratch & so except for this it would be sort of perfect & he said my pistons are fine but my car has been burning oil because I over-filled the oil but thank-you for all your help about that issue.It was Belle Tire that told me my pistons were bad & that I needed a whole engine over-haul when I said I had to add oil between changes.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 12-19-2012, 05:23 AM
Registered User
 
Join Date: Jan 2011
Location: Hopewell, Va
Age: 62
Posts: 1,159
Wiki Edits: 0

Thanks: 0
Thanked 116 Times in 112 Posts
serpentine belt & water pump belt

If the chirping noise is getting on your nerves get a new belt from Auto Zone. They carry the Goodyear brand. I had to change the belt on my wife's Jeep because of the same reason. I had just changed the belt with a Dayco belt from Advance Auto Parts. As soon as I started it up it was making a chirping noise. I try belt dressing but that didnt work. I took the belt off and returned it to Advance Auto for a refund and then went to Auto Zone and purchased a Goodyear belt. Never heard any noises after that .
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 12-19-2012, 05:30 AM
Registered User
 
Join Date: Dec 2012
Posts: 6
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
You are exactly right because that is what the repair shop told me up in Hamburg, Mich. except I got tempted by the 20% off at Advance Auto parts & got the belts there,however, I am .definitely, taking them back & purchasing the Goodyear belts instead .Thank-you so much.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 12-19-2012, 06:03 AM
Registered User
 
Join Date: Dec 2012
Posts: 6
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
Its Parts Plus (not Auto Zone)that sells the Goodyear brand & thanks again.I am geting ready to call Parts Plus as soon as they open this morning(which I believe is 9:00a.m.)
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Belt drive vs electric water pump Sapper Engine 2 06-29-2010 01:16 PM
serpentine belt water pump direction? trucks_chevrolet Engine 16 04-15-2008 10:49 AM
belt drive water pump VS/ electric eliot General Rodding Tech 3 08-15-2007 09:21 PM
going retro from serpentine belt system back to v-belt can i swap out the reverse ro motorhead1945 Engine 5 06-25-2007 06:56 PM
Electric Vs. Belt Driven Water Pump AustinG Engine 6 07-22-2006 08:32 AM


All times are GMT -6. The time now is 06:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.