Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Engine (http://www.hotrodders.com/forum/engine/)
-   -   Sewing Machine... 350 SBC XR282HR Comp Cam with Lunati Roller Rockers (http://www.hotrodders.com/forum/sewing-machine-350-sbc-xr282hr-comp-cam-lunati-roller-rockers-222442.html)

loudandproud 08-01-2012 06:58 PM

Sewing Machine... 350 SBC XR282HR Comp Cam with Lunati Roller Rockers
 
Motor has about 300 miles on it and i never really noticed but my engine sounds like a sewing machine. At first i feared it was a ring land, but a compression check showed that all was well.

Cam is a XR282HR, with LS7 lifters and Lunati Voodoo Rockers...
Im running procomp sheet metal valve covers and have plenty of clearance.
Preload is set up 1/2 turn past zero lash.

Is a sewing machine sound normal with an aggressive cam like this?

Its not terribly loud... i can hear it with the hood closed... but I can hear it with the hood open if i listen.

forgebench 08-01-2012 07:04 PM

That sound is pretty normal with aftermarket roller rockers. I've heard it on every engine I've had with them. My solid roller sounds like that with the hood closed.

loudandproud 08-01-2012 07:21 PM

its not that loud that i can hear it outside... every once in a while if i bring it up to around 2500 rpm I can here it in the cab.

No misses, or carrying on... motor runs like a raped ape and moves my 4000lb pickup pretty good, pretty damn good.

forgebench 08-01-2012 07:25 PM

As long as you tightened them down right I wouldn't worry about it. If it was super loud then you might need to readjust the preload but otherwise you'll be good. I've ran hydraulics a few times with aftermarket roller rockers, including a set of LS7 lifters, and they made that noise. I think you're good man.

loudandproud 08-01-2012 07:58 PM

thanks, ill try not to worry about it...

ap72 08-01-2012 08:29 PM

try a different oil and or viscosity

F-BIRD'88 08-01-2012 10:07 PM

Quote:

Originally Posted by ap72 (Post 1579290)
try a different oil and or viscosity

This made a noticeable difference on my motor with a XE Hyd cam.


All times are GMT -6. The time now is 06:27 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.