Small Block Mopar oil pump priming. - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 12-30-2007, 03:09 PM
Hippie's Avatar
Analog man in a digital world.
 

Last journal entry: HEI comparison.
Last photo:
Join Date: May 2003
Posts: 2,255
Wiki Edits: 0

Thanks: 3
Thanked 5 Times in 5 Posts
Small Block Mopar oil pump priming.

Primed the oil pump on my kids 318 today, at first I could see some oil flow in the lifter valley but then it stopped. I turned the engine 180 degrees 4 times while turning the oil pump. I pulled the oil pressure sending unit and tried again and as soon as I hit the trigger on my drill I had a geyser and oil everywhere so the pump is primed. I'm used to priming small block Chevies and seeing oil at the rockers, etc. but I'm not seeing oil movement at the rockers on this one. I have the rocker shafts installed correctly provided when the book says left and right they are referencing left and right as seated in the driver's seat. Is this normal or should I be worried? It doesn't seem right to me.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 12-30-2007, 03:44 PM
Registered User
 
Last wiki edit: Mopar tapered axle rear brake conversion
Last journal entry: What I'm doing now...
Last photo:
Join Date: Jan 2002
Posts: 4,267
Wiki Edits: 49

Thanks: 0
Thanked 4 Times in 4 Posts
There's a big difference between the SBC individual rocker arms and Mopar rocker shafts. Mopars generally won't spit oil everywhere because the rocker shafts and rockers don't require that much oil to lubricate properly. Chevys on the other hand will gaul the rockers in a heartbeat if they don't swim in oil.

My experience is with early hemis and big block Mopars but they all have rocker shafts and the oiling systems work pretty much the same. Each rocker shaft has one or two stanchions that have a small oil hole which must align with the oil supply hole in the head when its assembled. That's why there's a right and left side to them. As long as you have them on the correct side they will get oil, providing the oil passages in the heads or block aren't full of gunk.

The rocker shaft itself will fill completely with oil once the engine has started. An old engine builders trick was to fill the shafts with oil and put a little grease in the oil supply hole (on the rocker stanchion) to keep it from draining out. That would give you full rocker shafts at startup. Now days most people just remove the plugs and crank the engine to confirm good oil pressure and then reinstall the plugs for startup. What I do is take some STP and pour it on each rocker and the shaft before installing the valve cover then I don't have to worry if there is a slight delay in getting oil to the rockers.

Good luck.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 12-30-2007, 03:53 PM
Hippie's Avatar
Analog man in a digital world.
 

Last journal entry: HEI comparison.
Last photo:
Join Date: May 2003
Posts: 2,255
Wiki Edits: 0

Thanks: 3
Thanked 5 Times in 5 Posts
Quote:
Originally Posted by Centerline
What I do is take some STP and pour it on each rocker and the shaft before installing the valve cover then I don't have to worry if there is a slight delay in getting oil to the rockers.

Good luck.

Thanks CL, I coated everything with cam lube and soaked the rockers with oil. I triple checked to make sure I had the shafts aligned properly so I guess I'm good to go. Now he has to get the snow cleaned off it so we can roll it in and get the engine back where it belongs. I love building engines ( even Mopars ) but hooking them back up to a frozen, snow covered truck really sux.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
high volume and high pressure oil pumps can destroy cam and distributor gears! Knobie Engine 75 02-13-2011 02:22 PM
oil change- step by step instructions for women and men Fireball Hotrodders' Lounge 38 08-30-2008 07:39 AM
Big block mopar oil pump biggeboss Engine 1 06-14-2006 01:42 PM
high volume oil pump question jstaten Engine 4 01-15-2006 11:56 PM
Small block Mopar questions Jmark Engine 12 11-26-2004 09:25 AM


All times are GMT -6. The time now is 07:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.