Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Small paint bubbles/blisters
View Single Post
  #11 (permalink)  
Old 01-05-2013, 05:14 AM
69 widetrack 69 widetrack is offline
Faith - Respect - Trust
 
Last photo:
Join Date: Sep 2012
Location: Ontario
Age: 58
Posts: 3,508
Wiki Edits: 0

Thanks: 192
Thanked 637 Times in 572 Posts
[QUOTE=ReflectImage;1630742]That's a terrible feeling when something like this happens; I've been there! Like the other replies if your going to get help you need to tell what products & what procedure you used. From experience and advise from PPG that we received - you need to 'seal' before laying down the the color. This could be what happened if didn't you seal the primer surfacer before painting. It could be that the color was so hot (chemically) that it burned right into your surfacers and body filler and then trapped moisture under the surface. If you haven't solved the problem yet, as I see it the only way is to find out. Would be to first lay down a strip of masking tape on all four side of the bubble and shave it off with a razor blade. Then let the viewers know 1)what you see, 2) what products you use maybe then someone can give you hand in where to go next. Just so you know I am not current on todays 2 stage products, only experience is with one stage and sealing with with DP-40 before paint.[/QUOT

I wasn't going to reply but after thinking it over I decided I better and the only reason is that if someone else reads this they are not getting the right information.

ReflectImage....I don't mean to offend you but in this case you are wrong...If this is the information that a PPG rep gave you...The PPG rep was wrong. Sealer has absolutely nothing to do with what happened here, sealer is a product designed to even out poor substrates, for example, if you have a vehicle with several different substrates, say lacquer primer and or whatever Acrylic Enamel, or a vehicle that is not sanded with the fine grit required so sand scratches won't show when painted. If a vehicle is prepped properly and the substrate (either existing paint or a quality primer) is consistent, sealer is not required and has no bearing on what happened here.

The problem is either trapped moisture under the paint causing rust or existing rust that was not removed completely before painting.

So again ReflectImage, I'm not trying to offend, I'm just trying to correct...And yes, I was a Rep for PPG.

Ray
Reply With Quote