Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Small paint bubbles/blisters
View Single Post
  #15 (permalink)  
Old 01-05-2013, 08:12 PM
ReflectImage ReflectImage is offline
Registered User
 
Join Date: Feb 2012
Posts: 21
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Hello 69 Widetrack. No worry, I am too old to be offended and I am always ready to learn. Anyway you are most lightly right about this particular situation of small paint bubbles/blisters. With my situation, the deck lid brook out in little raised bubbles after sitting in the sun for a few hours. The Deck lid was chemically stripped down & dried before applying DP40 metal sealer, followed with body fillers and primers. I am sure we were using Ditzlers Polyurethane Black Paint, being black may have something to do with it. The mistake we made according to the rep (I want make a correction it was a Ditzler rep) he said we were supposed seal with DP40 before laying down the paint, to keep the paint from burning into the substrates. We took the deck lid down to metal & redid the body work, got it all in the same substrate and followed the rep suggestions, spayed on a light reduced coat of DP40, scuffed lightly with scotchbrite before laying down the paint. Wrong or right - it turned out great. To make a long story short - we continued to do other cars with the same process. This was a long time ago - have been retired for over ten years - I guess things have changed. Anyway, what happened to this thread starter?
Reply With Quote