Snap Ring Pliers Problem - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Garage - Tools
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-26-2006, 04:34 PM
Registered User
 
Last photo:
Join Date: Nov 2005
Location: Massachusetts
Posts: 74
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Snap Ring Pliers Problem

Im putting a Saginaw 4 speed back together and have run into a problem. I can't get the ring on that holds the front bearing on the main shaft. I worked this thing for over an hour and still can't get it on there. I tried internal and external pliers. Does anyone know a trick to getting this thing on? It's driving me nuts!

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-26-2006, 11:12 PM
Member
 
Last photo:
Join Date: May 2003
Location: Shreveport LA
Age: 65
Posts: 5,103
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
You need a proper set of lock ring pliers. If you're using the kind with the little projections on the tip, I feel your pain. I tried them and almost lost my mind, as well as a couple of fingers. One of these should do the trick:

KD 2534
Cal-Van 268-834
Plews 72-951
Craftsman 47386 or 00947386000
Mac P21A

Occasionally you'll have to de-burr the edge of the groove and/or the edge of the ring with a file.

Last edited by jimfulco; 05-26-2006 at 11:19 PM.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 05-27-2006, 08:27 PM
Registered User
 
Last photo:
Join Date: Nov 2005
Location: Massachusetts
Posts: 74
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I ended up using a small dremel cut off to make a small grove in each side of the ring so the little projections on the end of the pliers had a place to bite in and keep from slipping. Got it on there on the second attempt. Thanx for the help.
Reply With Quote Quick reply to this message

Recent Garage - Tools posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anti-gravity machine? NXS Hotrodders' Lounge 257 05-28-2006 10:48 PM
piston help, and or ring help blake carstensen Engine 2 12-08-2005 09:25 PM
Puzzling temperature problem on the hemi solved Centerline Engine 2 11-26-2004 04:48 PM
Piston Ring New Concepts brainsboy Engine 2 04-27-2004 04:55 PM
Fuel / Carb problem DoubleVision Engine 5 10-28-2002 06:18 PM


All times are GMT -6. The time now is 04:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.