speaker help - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > General Discussion> Hotrodders' Lounge
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-20-2003, 09:00 PM
Member
 
Join Date: Jul 2003
Location: geraldton western australia
Age: 29
Posts: 72
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
speaker help

i was playing around with my car stereo today and noteiced that my driveres side rear speaker was real quiet i had a look and only the tweater is working. i tried pushing the woofer and it fells locked up. has any one else had this problem??and can it be fixed ?

the speaker is not he best quality but not the worst eaither. its a kenwood kfc-1666 6 1\2 inch

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-20-2003, 09:16 PM
Member
 
Last photo:
Join Date: Jun 2003
Location: Tulsa, Oklahoma
Age: 32
Posts: 64
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I doubt that your speaker is "locked up". You shouldn't be able to move it a lot. It sounds to me like something isn't hooked up right. Check all of your connections. Maybe a tinsel lead on the speaker has come undone. Even if your speaker was blown you should get some static.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 11-20-2003, 10:01 PM
Member
 
Join Date: Jul 2003
Location: geraldton western australia
Age: 29
Posts: 72
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
it is definatly locked up the other speaker has about 5 mm movment but this one wont move at all. where the tweeter comes out the middle i was thinking of putting some oil in there in case some dirt had bound it up ??
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 11-20-2003, 10:43 PM
Silver_Camaro's Avatar
Superior Wheels Quality Tech
 
Last photo:
Join Date: Jun 2003
Location: Kansas
Age: 28
Posts: 385
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I've seen cases where voice coils burst and weld themselves to the magnet or jam up because of the burnt metal. This may be your case.. In which your gonna have to buy some new speakers.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 11-24-2003, 07:26 AM
Member
 
Join Date: Jul 2003
Location: geraldton western australia
Age: 29
Posts: 72
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
i say thats whats happend because i had a 100 watt per chanel amp runing them
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 11-24-2003, 12:28 PM
Dragon J's Avatar
Member
 

Last journal entry: Harley/Fire
Last photo:
Join Date: Feb 2003
Location: Just North of I-80 in Middle America
Posts: 533
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Blown voice coil for sure- in the past they were adjustable and I have repaired a couple as the magnets were bolted in place and could be realigned.... not so with components in the last 10 years. You are probably looking for new speakers!!
Reply With Quote Quick reply to this message

Recent Hotrodders' Lounge posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 09:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.