steering problems - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 01-22-2005, 11:12 AM
AMP's Avatar
AMP AMP is offline
New Member
 
Last photo:
Join Date: Dec 2004
Location: St. Louis
Age: 45
Posts: 12
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
steering problems

Well, engine is back in. Runs fine, but no power stearing put the car on jacks, and started it up, to find that the steering walked to the left at an idle? all lines look good, and it was working fine till the engine rebuild. (never disconected it)
Fluid is ok,belt,connections... What do ya think is the problem.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 01-22-2005, 01:21 PM
BOBCRMAN@aol.com's Avatar
Member
 
Last photo:
Join Date: May 2002
Location: Holly, michigan
Posts: 8,202
Wiki Edits: 0

Thanks: 27
Thanked 288 Times in 268 Posts
Start the engine and crank the steering wheel left to right from lock to lock a few times. Should clear up the problem. Air gets into the system from hanging loose and needs to be bled out.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 01-23-2005, 11:49 PM
Registered User
 
Join Date: Jan 2005
Location: Mountain Home,AR
Age: 59
Posts: 9
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
line collapse

Is it possible that when you pulled the motor out and left P/S attached that the pump hung down with hoses holding it? One of the lines possible could of collapsed. Sometimes you don't even know it has happened. I know this sounds stupid but crack open a line to bleed.
Good luck
Reply With Quote Quick reply to this message

Recent Suspension - Brakes - Steering posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 02:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.