Steering rack question - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 01-07-2004, 10:26 AM
Jag Daddy's Avatar
British Style with USA Muscle
 
Last photo:
Join Date: Mar 2003
Location: Valencia, California
Age: 57
Posts: 1,078
Wiki Edits: 0

Thanks: 7
Thanked 0 Times in 0 Posts
Steering rack question

I took my Jag out the other day for a nice long drive before I had to get it smogged. I know the rack has a leak so the system was low on fluid. I refilled the PS Pump and backed it down the driveway, man the steering wheel was hard to turn. If I'm driving at speed the thing turns great but at idle it really hard. Could there be air in the system? OR what causes this condition?

Regards
Mark

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 01-07-2004, 06:43 PM
adtkart@aol.com
 
Last photo:
Join Date: Oct 2002
Location: Newport News, VA
Posts: 3,220
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Could possibly have air in the system. Could also be that the belt is slipping. You also might have a pump that is going out, from being run low for too long. The higher RPM at highway speeds may be giving you enough pressure, where the lower speeds you don't have it.

Just my guess.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 01-09-2004, 08:12 AM
rally4x4racer's Avatar
beer and time
 

Last journal entry: right after paint
Last photo:
Join Date: Jan 2004
Location: ft bragg
Age: 36
Posts: 175
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
hey jag!

im not too familiar with jags, but do you have a brake booster running off the pumps vacuum?

if you want to try to bleed it also ( im not sure if this is done with the psp (pwr string pmp) cap on or off )
I imagine that may depend on if you do it with the vehicle running or not.
I did mine with it off then with it running and the cap on.

ATW (all the way) left and ATW right about 20 reps and check level.

you might flush the box too and refill/bleed.

im sure this isnt much help, but possibly something to look into.
Reply With Quote Quick reply to this message

Recent Suspension - Brakes - Steering posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 10:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.