Stereo Guru needed - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-28-2006, 08:49 PM
stea's Avatar
Member
 
Last photo:
Join Date: Feb 2003
Location: utah
Posts: 336
Wiki Edits: 0

Thanks: 7
Thanked 5 Times in 5 Posts
Stereo Guru needed

Didnt know whether to place this in the interior or the electrical forum.

I just bought a set of Alpine 6.5 "S" type speakers. They sound like ****. Any suggestions on a different speaker?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-28-2006, 08:54 PM
weirdbeard's Avatar
1976 Ranchero GT
 

Last journal entry: Almost time for the first drive!
Last photo:
Join Date: Feb 2006
Location: Ala BAMA! (Gump)
Age: 8
Posts: 1,454
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
May not be the speakers. The enclosure has very much to do with the sound. What do you have?
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-28-2006, 09:06 PM
stea's Avatar
Member
 
Last photo:
Join Date: Feb 2003
Location: utah
Posts: 336
Wiki Edits: 0

Thanks: 7
Thanked 5 Times in 5 Posts
They are mounted in a console I just built. I was told not to enclose them because It would not allow them to move. It sounds like a tweeter issue. They break up under a very light load.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 08-28-2006, 09:23 PM
weirdbeard's Avatar
1976 Ranchero GT
 

Last journal entry: Almost time for the first drive!
Last photo:
Join Date: Feb 2006
Location: Ala BAMA! (Gump)
Age: 8
Posts: 1,454
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Normally the speakers will come with specs for the size and type of enclosure. If you get it wrong it does not matter what kind of fancy speakers you have they will never put out like they should. You have ported, sealed and open back enclosures.You will not get the advertised frequency response with the wrong one. I would double check those specs.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 08-28-2006, 11:20 PM
njbloodline666's Avatar
I Love VTec
 
Last photo:
Join Date: Jul 2003
Location: fairview nj
Age: 28
Posts: 306
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
if its sounding like a tweeter, the enclosure will have nothing to do with it...are you running the speakers off an amp or the built in amp of the head unit. if you are using an external amp, make sure you have the amp set correctly...some of them have a low pass crossover built in, to basically cancel out high frequencies. for use with subs, this will never sound good with full range speakers.
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 08-29-2006, 09:43 AM
stea's Avatar
Member
 
Last photo:
Join Date: Feb 2003
Location: utah
Posts: 336
Wiki Edits: 0

Thanks: 7
Thanked 5 Times in 5 Posts
Just running them off the head unit.
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 08-29-2006, 10:51 AM
njbloodline666's Avatar
I Love VTec
 
Last photo:
Join Date: Jul 2003
Location: fairview nj
Age: 28
Posts: 306
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
are the polarities correct? are you using all 4 channels on the head unit or
(if you are using 4 speakers) do you have the speakers run in paralell or series for some reason some reason? are you running 2 speakers, and have the 4 channels bridged into 2? have you played around with the EQ settings?
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 08-29-2006, 01:13 PM
stea's Avatar
Member
 
Last photo:
Join Date: Feb 2003
Location: utah
Posts: 336
Wiki Edits: 0

Thanks: 7
Thanked 5 Times in 5 Posts
Nope just the regular hookup from the head unit. lf-lf, rf-rf. rr-rr and lr-lr.
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 08-29-2006, 09:45 PM
njbloodline666's Avatar
I Love VTec
 
Last photo:
Join Date: Jul 2003
Location: fairview nj
Age: 28
Posts: 306
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
check your grounds. i once grounded a headunit to a lightbulb and well that caused some problems. are you running resistor plugs and rf supressant plug wires by any chance? without these you will probably get interference. other than that im all out of ideas. sorry. alpine does not make the best speakers, but they still should sound that bad. does it only happen when its turned up.. if so, you may simply be overloading the amp. new speakers wont correct that.
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 08-29-2006, 11:45 PM
WHIPPININMY68's Avatar
urGTO=LEGEND myTEMPEST=CLASSIC
 
Join Date: Feb 2006
Location: Cali
Age: 26
Posts: 40
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Ive had a lot of experience with speakers i had a nice setup in a little honda accord dyno mated everything and built custom trunk floor and 2 12's 2 10's rockford fosgate and mtx and i had POLK AUDIO 6by9's and 5's and they were running off a alpine deck and a kenwood 1800 watt amp 2.5farad cap, till the deck got stollen then a buddy of mine said go with kenwood and kenwood is good. ANYWAY i think im not sure but you said they sound like crap well what kind of crap corny, liquidy, green...no no seriously like how? Do they distort or crack and are they singe, 2, or 3way speakers if you running subs you want just 2 way speakers highs and mids the subs take care of the lows. if your running 3 ways it's good because then they transfer some base too but it will only be what i call "sound bass" not "real bass". to better understand that i mean if you ever heard some one pull up next to you or from behind and it sounded like they had so much base like it seemed like it was right in your ear but as soon as they pulled forward it seemed like they turned off the radio ya thats the "sound bass" when you FEEL vibrations, or feel them inside your car or just period for that matter thats "REAL BASS". Anyway tell me what the sound is like when you say crap.
Reply With Quote Quick reply to this message
  #11 (permalink)  
Old 08-30-2006, 10:49 AM
stea's Avatar
Member
 
Last photo:
Join Date: Feb 2003
Location: utah
Posts: 336
Wiki Edits: 0

Thanks: 7
Thanked 5 Times in 5 Posts
They were cracking up real bad without adding much power. Last night I traded them out for a set of Rockford Fosgates T162C

http://www.rockfordfosgate.com/produ...1&locale=en_US.

Much much better but I dont think my head unit has enough power to push them. Their web site recommends that I amp them.

May have to buy an amp. For the bass Im currently running an Infinity Base Link Unit.
Reply With Quote Quick reply to this message
  #12 (permalink)  
Old 08-30-2006, 01:06 PM
njbloodline666's Avatar
I Love VTec
 
Last photo:
Join Date: Jul 2003
Location: fairview nj
Age: 28
Posts: 306
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
whats the rms wattage on the head?
Reply With Quote Quick reply to this message
  #13 (permalink)  
Old 08-30-2006, 03:28 PM
WHIPPININMY68's Avatar
urGTO=LEGEND myTEMPEST=CLASSIC
 
Join Date: Feb 2006
Location: Cali
Age: 26
Posts: 40
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
You might also want to check the treble, bass, left right and so on to make sure nothing it getting more than the others.
Reply With Quote Quick reply to this message
  #14 (permalink)  
Old 08-30-2006, 03:39 PM
stea's Avatar
Member
 
Last photo:
Join Date: Feb 2003
Location: utah
Posts: 336
Wiki Edits: 0

Thanks: 7
Thanked 5 Times in 5 Posts
I spent hours trying to adjust it right. The headunit has a pretty detailed built in eq. Would baffleing the speakers help?
Reply With Quote Quick reply to this message
  #15 (permalink)  
Old 08-30-2006, 03:46 PM
WHIPPININMY68's Avatar
urGTO=LEGEND myTEMPEST=CLASSIC
 
Join Date: Feb 2006
Location: Cali
Age: 26
Posts: 40
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
it wouldnt help the sound, if your looking to make the sound louder ad a amp if you want it to sound good without ratteling and to carry sound then dynomat it or inclose the back. Although theoritically if the speaker sounds bad and theres nothing wrong with it and or the input to the speaker has nothing wrong with it, it probabally isnt the speaker.
Reply With Quote Quick reply to this message

Recent Hotrodding Basics posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade: 1980 Stereo in 1969 Car A-BodyFan Electrical 2 02-04-2006 09:25 PM
stereo problems texasford Electrical 5 01-25-2006 03:08 PM
installed low power stereo, now the car stutters when RPM's drop Dizturbed One Electrical 5 06-15-2005 03:34 PM
Cam Guru Needed..... NitrousJunkie Engine 4 05-04-2005 08:38 PM
700R4 guru needed igotachevyor2 Transmission - Rearend 0 12-05-2002 06:00 PM


All times are GMT -6. The time now is 02:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.