Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Stock SBC 350 Crate Motor valve chatter under load
View Single Post
  #7 (permalink)  
Old 01-06-2013, 07:56 PM
71fj40guy 71fj40guy is offline
Registered User
 
Last photo:
Join Date: Jan 2013
Posts: 51
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally Posted by starnest View Post
Detonation.
Excessive valve lash (or bent push rods) would rattle just as much at free rev as under load. Plus you would probably hear it at idle.

Verify timing marks and pointer as stated above.
Initial advance at 12 might be a bit much, especially if your running 87 octane.
Also, check vacuum advance operation, if it isn't working right you'll have too much advance when you press the throttle under load.

Is this a new engine or did you change anything just before the noise started?
If the engine was running fine and then starts pinging w/o changing ignition/timing, then it could be running lean (causes detonation). If so check fuel delivery to carb, read the plugs, etc. With the ethanol in todays gas, it doesn't take long before the moisture can accumulate in the carb and cause corrosion and mess up your mixture.

Good luck.
The motor has 60,000 miles on it. It was running fine then I cleaned the engine bay and got some water in my old MSD pro billet dizzy from that point it went south. I started by checking and replacing all the plugs, then wires, then the cap and rotor, and finally the distributor.
If I have it set to anything less than 12 at idle I get valve chatter and it idles rough.
The chatter also started before I did the valve adjustment.
Reply With Quote