stored 454SS won"t start (TBI prob??) - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 09-01-2010, 02:09 PM
Registered User
 
Join Date: Sep 2010
Location: rapid city south dakota
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
stored 454SS won"t start (TBI prob??)

I have a 1990 454SS pickup with 17,000 mi that I purchased new. The truck is totally stock. Unfortunately I let it sit too long recently and it will not start. Cranks good and has good spark. Runs if I dump a little gas in the intake. Fuel pump runs and seems to have good fuel flow to the TBI but nothing from the injectors. Any good ideas on the failed or plugged component?? Thanks BD

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 09-01-2010, 02:41 PM
T-bucket23's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Engine basic condition - how to check Last photo:
Join Date: Aug 2005
Location: Massachusetts
Age: 56
Posts: 5,053
Wiki Edits: 26

Thanks: 6
Thanked 92 Times in 78 Posts
Quote:
Originally Posted by dockpalm
I have a 1990 454SS pickup with 17,000 mi that I purchased new. The truck is totally stock. Unfortunately I let it sit too long recently and it will not start. Cranks good and has good spark. Runs if I dump a little gas in the intake. Fuel pump runs and seems to have good fuel flow to the TBI but nothing from the injectors. Any good ideas on the failed or plugged component?? Thanks BD
Hearing the pump doesn't mean anything, put a pressure gauge on it.
If it has been sitting a long time I would check out the electrical part of the TBI for bad grounds. It was a fairly common issue and sitting can make it worse
__________________
Artificial Intelligence is no match for Natural Stupidity



Chet
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need some help with 1986 GM 305, TBI or Carbed??? dieselcruiserhead Engine 8 12-19-2010 07:32 AM
tbi probs...won't start jerry3902 Electrical 17 03-27-2008 08:33 AM
TBI 350 No start... AMDAP Engine 1 06-27-2007 05:40 AM
89 GM TBI 350 - Quit Running...Where to Start? Rambo_The_Dog Engine 10 05-18-2007 06:21 PM
My truck wont start. 91 serria 350 tbi montea Engine 17 12-17-2006 04:23 PM


All times are GMT -6. The time now is 01:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.