Stuck oil pressure guage - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 06-24-2010, 06:09 PM
Registered User
 
Last photo:
Join Date: Aug 2009
Location: Toronto Ontario
Posts: 242
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Stuck oil pressure guage

Hey guys, I have a 1995 Oldsmobile Achievea S and the oil pressure guage is pegged all the time. I have seen a few other Achiveas that have problems with there oil pressure guage as well, but its usualy jumping around or gets jammed up for a sec. I was given this car by my Grandfather when he passed and ever sine then the oil pressure is pegged at the max.

It makes no difference if the car is on or off, it just stays right there at the max. I have noticed that when I go to start the car it moves up a milimeter or so and stops again. I dont know what took me so long but I really want to get this fixed. I think having my oil pressure guage working is pretty damn important XP

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-24-2010, 06:43 PM
eloc431962's Avatar
Evil Wicked Mean And Nasty
 
Last wiki edit: Pilot bearing and bushings
Last journal entry: roof repair
Last photo:
Join Date: Nov 2008
Location: back in the garage.
Posts: 13,762
Wiki Edits: 37

Thanks: 50
Thanked 28 Times in 24 Posts
You could Put another gauge in it, Or it could be a bad sending unit.JMO

If you said it had a light i would think it could be the oil pressure sending switch.

Cole
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 06-24-2010, 07:46 PM
Registered User
 
Last photo:
Join Date: Aug 2009
Location: Toronto Ontario
Posts: 242
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Well since the guage sticks there even when the car is off I am guessing its the gueage its self. Is there any way to get it un stuck?
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 06-24-2010, 10:04 PM
DOCTOR DC's Avatar
NUCKINFUTS MOTORSPORTS
 
Join Date: Apr 2010
Location: PACIFICNORTHWEST
Posts: 111
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
you can pull the cluster and turn it upside down, then roll it slowly back upright. If it goes right back to pegged position after key up then u need to find that short to ground.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
chevy 350 four bolt main oil pressure problam snelkie@ Engine 3 06-13-2011 06:25 PM
4.3 Oil Pressure problems Blazin_Jason Engine 6 01-23-2010 06:42 PM
lets have a oil pressure discussion k-star Engine 9 02-05-2007 11:31 AM
No Oil Pressure!! MartyMart9@aol.com Engine 43 04-26-2005 06:37 AM
elect oil pressure guage 87 monte ss Electrical 4 10-14-2004 02:48 PM


All times are GMT -6. The time now is 03:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.