Stuck valve? Ford T-bird - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-02-2008, 09:22 PM
Registered User
 
Join Date: Aug 2007
Location: New York
Posts: 88
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Stuck valve? Ford T-bird

Im helping a friend with 70 T-bird.Its a 429 with about 75,000 miles on it. It was sitting for about 18 years in a garage we got it running (marvel mystery oil in the cylinders, changed the oil, fresh gas cranked with the plugs out then started it up) It seems to run ok at idle dosent smoke and the oil stayed clean but its got this miss when you put some load on the engine. I changed the plugs and wires new points checked the dwell new cap and rotor but the front plug drivers side dosent seem to be doing anything theres spark there too but when pulling off the wire the idle just stays the same and the plug seems slightly wet (seems to be oil, very little) Is it a stuck valve ? I was thinking of pouring some Marvel mystery oil down the carb while it was running to see if it would clean them off. I havent taken off the valve cover yet.Anything else I can try? Could it be the rings? If so wouldnt I have blue smoke from the exhaust (theres no smoke blue black white) .

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-02-2008, 10:50 PM
Registered User
 
Last photo:
Join Date: May 2006
Location: Kamloops B.C.
Posts: 231
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
stuck valve

Pull the valve cover and look at the rockers. A compression check is in order . Happy sleuthing.
Clint
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 11-03-2008, 12:06 AM
Registered User
 
Last photo:
Join Date: Nov 2008
Location: Langley, BC
Age: 27
Posts: 55
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
pull the covers and hit each valve with a rubber mallet, if a valve is stuck that should free it up, gl
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 11-03-2008, 08:50 AM
onebadmerc's Avatar
I need a bucket of arc sparks
 
Last wiki edit: How to identify SB Ford heads without pulling them
Last journal entry: trunk floor
Last photo:
Join Date: Jan 2003
Location: Florence Colorado
Age: 43
Posts: 901
Wiki Edits: 1

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by automods
pull the covers and hit each valve with a rubber mallet, if a valve is stuck that should free it up, gl
That will pop the keeper and drop the valve, don't do it unless you want to pull the head.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 11-04-2008, 07:55 PM
Registered User
 
Join Date: Aug 2007
Location: New York
Posts: 88
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Bent pushrod is the culprit. I ordered a new set. What is the procedure to
set the rocker arms after I install the new ones?Its naturally a hydraulic cam.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
700R4 Why are the TCI manual valve body instructions so lousy? Bayley Transmission - Rearend 24 02-16-2009 01:49 PM
stuck valve problems hammerhead Engine 7 10-21-2008 11:33 PM
Ford 272 Distributer is stuck ?? jimcar-9 Engine 8 06-12-2007 06:37 AM
B&S intake valve stuck open m1e9r5c6 Hotrodding Basics 7 04-30-2004 05:13 AM
ford hi-po valve train fordracing Engine 6 03-17-2003 08:56 PM


All times are GMT -6. The time now is 12:38 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.