"Subframe Connectors" - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > General Discussion> Hotrodders' Lounge
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-12-2006, 07:27 AM
malc's Avatar
Living At The Speed Of Life
 
Last photo:
Join Date: Jun 2003
Location: España Right Coast
Posts: 3,322
Wiki Edits: 0

Thanks: 117
Thanked 158 Times in 130 Posts
"Subframe Connectors"

Or whatever people like to call them, I finally decided to remove mine.
We have speed bumps so big here I was having to drive the car over them under power as the "connectors" were dragging.
It felt like the car was being arched in the middle.
A big thank you to the "winged ricers" here, who due to their racing on the main drag got these bloody things installed.
Attached Thumbnails
Click image for larger version

Name:	S_Connectors.jpg
Views:	126
Size:	235.3 KB
ID:	12128  

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-12-2006, 03:45 PM
crazy larry's Avatar
Member
 

Last journal entry: better comparison before and after shots
Last photo:
Join Date: Oct 2002
Location: East Texas
Age: 43
Posts: 2,298
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Malc, why do you live in spain?



you just need to make more hp. hop over the speed bumps.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 05-12-2006, 03:49 PM
Registered User
 
Last photo:
Join Date: Mar 2006
Location: Cali
Posts: 123
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Does your car still scrape?
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 05-13-2006, 02:24 AM
malc's Avatar
Living At The Speed Of Life
 
Last photo:
Join Date: Jun 2003
Location: España Right Coast
Posts: 3,322
Wiki Edits: 0

Thanks: 117
Thanked 158 Times in 130 Posts
I came to Spain from Germany to work, now I´m like embedded here,
everythings fine, except speed bumps !!
The problem is my wheelbase and the car is also lowered.
When the front wheels start to go off the ramp the rears are not quite on it.
I´ve not used it yet but I do know the problem will not reoccur.
These bumps also double for pedestrians to cross the road, maybe a Spanish driver doese´nt see a pedestrian unless he is at eye level.
In some towns they are unpainted and the streets poorly lit, that´s when I found one at 30mph, thought I´d left the whole drivetrain behind.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 05-14-2006, 01:10 AM
malc's Avatar
Living At The Speed Of Life
 
Last photo:
Join Date: Jun 2003
Location: España Right Coast
Posts: 3,322
Wiki Edits: 0

Thanks: 117
Thanked 158 Times in 130 Posts
Drove the car yesterday and it goes over the bumps without hanging up.
Upside, I noticed the car doese´nt creak and groan like it did with the connectors.
Reply With Quote Quick reply to this message

Recent Hotrodders' Lounge posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 08:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.