Swapping engines from a 89 blazer 4x4 4.3l t.b.I to a 88 s10 4x4 2.8l t.b.I. - Page 2 - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #16 (permalink)  
Old 05-29-2011, 03:31 PM
Registered User
 
Last photo:
Join Date: Jan 2007
Location: canada
Posts: 564
Wiki Edits: 0

Thanks: 0
Thanked 3 Times in 3 Posts
no. all the wires go into a plug that plugs into the fusebox. theres a bolt holding it in
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #17 (permalink)  
Old 05-29-2011, 03:40 PM
Registered User
 
Last photo:
Join Date: Nov 2010
Location: Calgary,Alberta,Canada
Posts: 211
Wiki Edits: 0

Thanks: 0
Thanked 8 Times in 7 Posts
take a look at the square connector where the harness goes thru the firewall. there is a bolt in the middle of that plug. unscrew the bolt and the engine harness should unplug from the firewall. i think. check it out.
the motor mounts should just bolt on. once you get the old 2.8 out, unbolt the mounts from the frame section, then bolt in the right ones. bingo. my son did the same thing to his 83, except he grafted a blazer engine and harness, including dash etc, into his pickup. it was a 4x4 so a few things get in the way for access, but it is not a hard thing to do. don't weld anything in unless there is absolutely no other way. the y pipe aqnd everything fits from the 4.3 that he used.
92 blazer 4.3 auto 4x4 into 83 4x4 reg cab long box. he did a 2" body lift at the same time, but that was a rabbit trail and didn't affect how anything else fit, other than some brake lines and the shifter, rad mounts and engine fan shroud mostly. if you need them i can send some opics if i can find trhem. let me know if you need them.
dsraven
dsraven
Reply With Quote Quick reply to this message
  #18 (permalink)  
Old 05-29-2011, 06:31 PM
Registered User
 
Last photo:
Join Date: May 2009
Location: S/E Michigan
Posts: 653
Wiki Edits: 0

Thanks: 0
Thanked 9 Times in 9 Posts
I would suggest you get at least 2 things, a digital camera and a copy of the chassis service manual(Helms, not Chiltons). The manual will show you how everything comes apart, and the camera will let you take pictures of sub assemblies so you can remember how they re-install correctly.
You'll be much better off if you un-bolt everything you possibly can, anything you have to cut or torch ends up being a possible issue later on.
Reply With Quote Quick reply to this message
  #19 (permalink)  
Old 05-29-2011, 09:54 PM
Registered User
 
Join Date: Apr 2011
Location: Ramsey, MN
Posts: 47
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Alrite I have no idea how to swap the wiring harness... Any ideas or advice?
Reply With Quote Quick reply to this message
  #20 (permalink)  
Old 05-29-2011, 10:01 PM
Registered User
 
Join Date: Apr 2011
Location: Ramsey, MN
Posts: 47
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Ya but the thing is that in order to get to the nuts on the bolts of the mounts I gota drop the front end, there's no space to get a wrench or anything on the nuts with the front end right underneath the only opening the nuts
Reply With Quote Quick reply to this message
  #21 (permalink)  
Old 06-21-2011, 07:44 PM
Registered User
 
Join Date: Apr 2011
Location: Ramsey, MN
Posts: 47
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
So I got the whole motor and powertrain in my s10 and everythings is hooked up that know of but every time I turn the key to the run position it pops the ecm1 fuse and I can't figure out why, any ideas?
Reply With Quote Quick reply to this message
  #22 (permalink)  
Old 06-23-2011, 06:13 PM
Registered User
 
Join Date: Apr 2011
Location: Ramsey, MN
Posts: 47
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
What shout I look for? What would be the most probable cause of popping the ECM1 fuse after doing this motor swap?
Reply With Quote Quick reply to this message
  #23 (permalink)  
Old 06-23-2011, 07:04 PM
Registered User
 
Last photo:
Join Date: Jan 2007
Location: canada
Posts: 564
Wiki Edits: 0

Thanks: 0
Thanked 3 Times in 3 Posts
Quote:
Originally Posted by The donkey
What shout I look for? What would be the most probable cause of popping the ECM1 fuse after doing this motor swap?
check for a pinched wire. pink with black stripe. feeds the ecm, injectors and electronic spark control module
Reply With Quote Quick reply to this message
  #24 (permalink)  
Old 06-28-2011, 08:43 PM
Registered User
 
Join Date: Apr 2011
Location: Ramsey, MN
Posts: 47
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
So I figured out that I have to swap the hole inside harness underneath the dash, I can't follow the fuel pump wires and sum other wires. Can anyone get me some in depth wiring diagrams or info on a 1988 s10 2.8l and a 1989 s10/blazer 4.3l
Reply With Quote Quick reply to this message

Recent Hotrodding Basics posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1998 blazer tranny blew can I swap engines disice1011 Transmission - Rearend 1 12-04-2008 01:31 AM
plz help s15 blew up. 98 blazer tranny blew cani swap engines disice1011 Engine 2 12-02-2008 09:33 PM
swapping engines in a ford 350 woodmanscott@hotmail Engine 4 11-23-2007 08:18 AM
swapping engines Ben D Engine 2 03-03-2006 07:06 AM
Swapping engines. Skunk Engine 2 11-07-2004 01:20 PM


All times are GMT -6. The time now is 04:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.