T-350 - acts like power braking after rebuild? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-29-2012, 07:33 AM
Registered User
 
Join Date: Jan 2009
Location: utah
Posts: 93
Wiki Edits: 0

Thanks: 0
Thanked 2 Times in 2 Posts
T-350 - acts like power braking after rebuild?

I have a TH350 that acts like you are standing on the brakes after rebuild in manual low and manual second gear, acts better cold than hot. Once hot this thing really acts up. But even hot once you go into drive you would not even think there was a probelm. All pressures are within the normal range. Reverse is fine. Drive is fine. I has an aftermarket shifter in it which was adjusted from low, I have not pulled the pan to check the detent lever versus the shifter. Maybe holding somewhere between manual 1st and 2nd allowing the low/reverse clutches to come on?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-29-2012, 08:41 AM
Registered User
 
Last photo:
Join Date: Oct 2012
Location: Texas Hill Country
Posts: 78
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
who rebuilt t it ? How does it act if you start out in drive,,and let it do it's own thing from 1st to 2bd and to 3rd ??
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 10-29-2012, 11:21 AM
Registered User
 
Join Date: Jan 2009
Location: utah
Posts: 93
Wiki Edits: 0

Thanks: 0
Thanked 2 Times in 2 Posts
I rebuilt it. Acts fine when you start in drive. Maybe a little sluggish?
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 10-29-2012, 11:34 AM
Registered User
 
Last photo:
Join Date: Oct 2012
Location: Texas Hill Country
Posts: 78
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
P M me, I know a guy........got to go Lowes, will check when I get back
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 11-01-2012, 07:51 PM
Registered User
 
Join Date: Sep 2012
Posts: 69
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
you have to many clutches under the pump. been there
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 11-02-2012, 10:45 AM
Registered User
 
Last photo:
Join Date: Oct 2012
Location: Texas Hill Country
Posts: 78
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I agree with Ruthless..... I talked to my 'expert' friend, agrees you could have too many plates in the clutch, as most rebuild kits today are kinda universal. as too the number fo parts in it . Example, the same tranny is used for the 6 cyl, only it uses a different pressure plate ( I think the said thicker), so there would be a space in there in the V8 , ( I also remember this space ) in the clutch pack where another disc would fit. The con fusing part would be seeing a stack of new( say 7 ) plates where yours had 6, and you go ahead and put 7 in.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
350 powergilde acts like it is in drive, won't start guinness Transmission - Rearend 3 03-04-2012 03:27 PM
350 sb just rebuilt and it will not turn at all acts like its seized up Hpbbster72 Engine 9 09-16-2004 04:57 PM
power braking 85stang Transmission - Rearend 9 10-25-2003 10:23 PM
Need help with power braking options Maverick Hotrodders' Lounge 11 10-11-2002 11:51 AM


All times are GMT -6. The time now is 05:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.