T-400 leaks real bad. - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 03-17-2007, 10:02 AM
Registered User
 
Join Date: Mar 2006
Location: WV
Posts: 37
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
T-400 leaks real bad.

I just pulled the 400 turbo back out of the car. It looks like it is leaking from every possible place it could! I had a guy rebuild it probably 2 years ago but it dont have 300 miles on it since the rebuild. I know it shouldnt leak at all but a little leak i could deal with, but it acts like its building preasure and coming out everywhere. What can i look for. How can u tell if the vent on top is clogged? Also the tranny didnt have a dipstick and i put the one out of the 700r that was in the car to start with. Is this dipstick the same as a 400's? or is it causing me to over fill the trans. It looks as if its leaking at the linkage port, Speed od. port, the pan, maybe a very little out of the front pump seal. The car is a 84 monte ss, ~450 hp 350, 3800 ati stall, and of course 400t tranny. The 400t come out of a mid 70s 3/4 ton chevy truck. Thanks for any help.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 03-17-2007, 03:35 PM
Registered User
 
Join Date: Mar 2006
Location: WV
Posts: 37
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
The vent isnt stopped up, Id on the side is 76-CP 31178.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 03-18-2007, 07:09 PM
Registered User
 
Join Date: Mar 2006
Location: WV
Posts: 37
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
How hard is it to change these seals? At the linkage, speedod. Do they go from the inside, or outside?
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 03-18-2007, 07:27 PM
71 c-10's Avatar
just a kid and his truck
 
Last photo:
Join Date: Sep 2003
Location: VA
Age: 27
Posts: 351
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by GEARHEADWV
How hard is it to change these seals? At the linkage, speedod. Do they go from the inside, or outside?
Speedo should be an O ring, the shifter you will need a special tool that grabs the seal and will pull it right out, its like a hallow bolt with kinda sharp threads
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 03-18-2007, 10:11 PM
Deuce's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Choosing a trailer
Last journal entry: Jan 13 2013
Last photo:
Join Date: Aug 2002
Location: Deuceland USA
Age: 66
Posts: 5,657
Wiki Edits: 6

Thanks: 0
Thanked 9 Times in 9 Posts


Simple tool to remove and reinstall the shift lever seal ... KD #2393
About 10 dollars at most decent auto parts stores ... works great.

Deuce ... Moderator
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 03-19-2007, 08:12 PM
71 c-10's Avatar
just a kid and his truck
 
Last photo:
Join Date: Sep 2003
Location: VA
Age: 27
Posts: 351
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
^^^^ exactly
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turbo 400 leaks into transfer case latheman Transmission - Rearend 2 02-13-2004 06:09 PM
De-stroke 400 mouse or not? 54Guy Engine 8 08-02-2002 06:49 PM
Need timing advice real bad 54 Chevy Engine 4 07-25-2002 07:09 PM
I need help......real bad TOTALNOVICE Engine 8 06-29-2002 08:09 PM
need advice bad! 400 small block irocan Engine 0 02-10-2002 04:17 AM


All times are GMT -6. The time now is 02:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.