T-400 will not go into 3rd with out lifting. - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 04-30-2012, 03:07 PM
Registered User
 
Join Date: Apr 2012
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
T-400 will not go into 3rd with out lifting.

I have a TH400 I rebuilt for Drag Racing. I put the TCI full manual valve body kit in and used TCI's rebuild Kit also put a Hughes Pump on it with 32elem sprag. It works correct except I have to lift my foot for it to go into 3rd. it will stay in 2nd until I lift my foot.

I have checked the gov, I dont think its that. Also can I completly eliminate the Gov. ? If so how ?


Thanks for any help !

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-01-2012, 10:19 AM
S10xGN's Avatar
Gotta love a turbo!
 

Last journal entry: Body on Frame today.
Last photo:
Join Date: Aug 2004
Location: Port Neches, TX
Age: 61
Posts: 1,730
Wiki Edits: 0

Thanks: 0
Thanked 68 Times in 64 Posts
I'm pretty sure an e-mail or phone call will get you the correct answer...

Russ
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lifting engine v8hed Engine 8 11-17-2009 06:49 PM
Everything is lifting Derkyb Body - Exterior 6 09-05-2008 08:53 AM
89 2500 with a t-400 , no 2nd 3rd gear calhoun Transmission - Rearend 3 02-04-2008 09:40 PM
lifting my chevy burninrubbah617 Suspension - Brakes - Steering 1 01-19-2006 07:04 AM
lifting an engine 1961_MGA Engine 5 10-16-2003 12:15 PM


All times are GMT -6. The time now is 09:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.