Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - t p i pinging problem 305 engine
View Single Post
  #4 (permalink)  
Old 11-14-2012, 06:16 PM
LATECH's Avatar
LATECH LATECH is offline
Hotrodders.com Moderator
 

Last journal entry: Motor - vator
Last photo:
Join Date: Jul 2010
Location: Northeast Pennsylvania
Posts: 5,229
Wiki Edits: 0

Thanks: 210
Thanked 260 Times in 242 Posts
Quote:
Originally Posted by chphlds View Post
hey guys.need help badly.havea 34 ford with a 1986 305 tuned port engine that i just purchased,my problem is it pings,even with octane boost.it has the plug for an knock sensor,but none installed.it has maf.
engine serial #v06c2dda.which tells me its out of a firebird.the stock ecm
is supposed to be-1227165,but it has a 16198262 .anyone know if they are compatable?it runs fine,except for the pinging,but also needs 10 minutes warm up time ,or it stalls.mabe a different problem but would like to solve pinging befor she goes away for winter storage.any ideas would be appreciated greatly.
The 1227165 is the correct ECM for the car, the prom would be where the difference is between a 305 tpi and the 350 tpi for those years
The 16198262 is not compatible as it is SPEED density not AIRFLOW density. No MAF input is why it is lean and pingy ...etc...runs crappy when cold.
Definitly dont run the 16198262.
An 16198259 is a direct replacement compatible number for your ECM, of course the prom may need to be changed, or get a new one burned for your upgrades
you need a knock sensor if you want the best performance overall and to protect your engine.Dont overlook it.
__________________
Fact is stranger than Fiction
Reply With Quote