Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - t p i pinging problem 305 engine
View Single Post
  #5 (permalink)  
Old 11-14-2012, 07:42 PM
hcompton's Avatar
hcompton hcompton is offline
Old & Furious
 
Join Date: Oct 2012
Location: MD
Age: 42
Posts: 1,074
Wiki Edits: 0

Thanks: 6
Thanked 90 Times in 87 Posts
Those engines should not be prone to knocking. But if it had knock sensor and it was removed it should be in limp mode. You may want to put a timing light on the car and go thru the factory proceedure to set the timing manually. It might be to far off for the computer to fix. Also is the dizy in good shape. Cap, rotor, coil and moduale in good shape?

Did you change the plugs maybe the plugs are too hot or wrong type for the engine. Sorry cant help much with tpi i took mine out and tossed it on the floor of the shop. But the codes should tell some part of the story.

Check the computer number and see what it fit. Its probably for a firebird as well. They normally will have several ecus for each car. Std/auto and hardtop/convertable plus all the factory options. Not all ecus are provisioned for all features. Some cars my not require a knock sensor so the wireing and circuit for the sensor will not be built into the ecu.

Now of the knock sensor has been removed and the wires shorted this might allow the computer to advance the timing searching for the knock point. Not sure how smart the older ecus are. But it might have the timing maxed all the time thinking its running super fuel and not knocking so more timing is needed. But usally its more than just shorting wire together to trick the computer the knock sensor is happy.
Reply With Quote