Tach reading 500 RPM or so lower than actual - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 03-09-2010, 04:24 PM
Registered User
Last photo:
Join Date: Jul 2009
Location: Utah
Posts: 68
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Tach reading 500 RPM or so lower than actual

So i have a Mallory ignition box, dist, and an autometer 5" tach. When i first fire up the motor it will read a correct RPM for a few moments then drop 500 RPM. My timing light shows the correct RPM which is about 500 RPM higher than what my tach is showing. So at idle its reading 400rpm when its really 900.
I have New coil, new cap, new rotor, new ignition module why the odd job jumping around on my tach? Could it be the mallory box? Its a hyfire VII's.


Reply With Quote Quick reply to this message
Sponsored Links
  #2 (permalink)  
Old 03-09-2010, 07:59 PM
Crosley's Avatar
Global Moderator
Last wiki edit: T-350 rebuild tech
Last journal entry: Morris Front suspension
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,719
Wiki Edits: 1659

Thanks: 661
Thanked 196 Times in 177 Posts
How new of design is the Autometer tach?

A buddy had a Autometer tach that was off.. turned out the programing in the tach was not correct. Autometer tech walked him through the re-program procedure on the phone
Dont worry how old you are... it is the mileage on your body that adds up.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Exhaust Diameter Formula ChevelleSS_LS6 Engine 11 04-27-2012 10:21 PM
blower idle rpm problem Ratoflic Engine 7 12-01-2008 04:31 AM
vortec heads on sbc 400 camino_man Engine 16 11-11-2005 02:33 AM
351 windsor running rich ???? ve3ham Engine 19 08-08-2005 01:48 PM
Is 2 1/2 pipes big enough? Mustang_Killa66 Engine 7 02-12-2004 09:04 AM

All times are GMT -6. The time now is 12:52 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.