Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Engine (http://www.hotrodders.com/forum/engine/)
-   -   Tbi chevy 350 hesitation. (http://www.hotrodders.com/forum/tbi-chevy-350-hesitation-181489.html)

scout2of6 07-22-2010 12:11 PM

Tbi chevy 350 hesitation.
 
Ive been dealing with a rough running TBI project. Was backfiring and bogging really bad. Finally after a lot of work and help from all of you, Ive got her running good. Starts good, idles good, very snappy throttle. The only thing now is a hesitation when in gear with aggressive throttle. Still seams like a vacuum leak but I cant find any. Could it be a problem with the torque converter. Im running a TH 400. Don't know a ton about Torque Converters but was wondering if a bad one or one with the wrong stall could be causing this.

Thanks

Adam65 07-22-2010 12:52 PM

Checked your throttle position sensor volts? It may need adjusted (some are slotted) to give a quicker squirt of fuel (like an accelerator pump).

scout2of6 07-22-2010 01:44 PM

What should the volt reading be?

va4cqd 07-22-2010 02:56 PM

what vehicle and engine are you asking about?

scout2of6 07-22-2010 07:14 PM

The engine is out of A 1990 chevy p/u. its a TBI 350.

JohnnyC 07-23-2010 07:03 AM

tbi bogging
 
hello,
sorry to jump in on your thread but how did you get it to run better? mine is doing the same thing.
thanx! :(

scout2of6 07-23-2010 10:55 PM

I changed almost everything. Tried different throttle bodies, different injectors, ERG valve, new plug wires, new fuel pump, cap, rotor,and distributor. Most of these were extra parts that I had. sure couldnt afford to replace all of that stuff with new. Checked numerous times for vaccum leaks. Every time I changed something it seemed to run a little bit better. I finally found a bad plug even though the plugs were all new. that helped the most but still a little hesitation. You might know this but I put a timing light on each plug wire and point it at my hand and watch for a little bit. you can see if you have a miss in a cylinder this way. It helped me find the bad plug. Anyway hope this helps. Good luck, I feel your pain.You will know the TBI stuff inside and out when your done. Let me know how it turns out.

JohnnyC 07-26-2010 06:21 AM

bogging tbi, egr, cat conv, code 32, etc.
 
yeah, im getting there. actually replaced the regulator diaphram in the TB this weekend. no different, so i got ticked and took off my catalytic converter, reamed it out, and put it back on. didn't fix the prob, of course, but at least now its got some more pep so i can merge or get out of my dangerous driveway. throwin egr codes now though?! anybody have any ideas about this. i was told obd I systems won't throw codes without a cat. guess that wasn't true. :confused:
Great tip about the timing light!


All times are GMT -6. The time now is 08:20 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.