tearing up convertors - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-22-2008, 08:13 AM
Member
 
Last photo:
Join Date: Aug 2005
Location: Virginia
Posts: 875
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
tearing up convertors

I have a 396 in a full size mud truck that is pretty hot. I tore up one convertor after about 3 trips out racing and got another one (same company) and I think I am having the same problem after as many runs. When the convertor is new it will flash high as advertised (about 4500) but the next few times I have it out the truck will jump when put in gear and when I smack it the tach doesnt climb as rapidly as when the convertor is new and it feels sluggish like its too tight (this is the second one and I havent been out but about 6 times this year). This convertor is making me look like an ***. I guess my question is would there be something wrong in the th400 that could be causing it? The manf says it should be good for 800 hp and I am pretty sure it doesnt have that much...maybe 650 if I'm lucky

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-22-2008, 11:30 AM
Registered User
 
Join Date: Nov 2005
Location: Duffield ,Va
Age: 67
Posts: 526
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
I don't know the brand, but there are some converters that are junk, good converters come in a pretty high price range, about $600 up.

Also when you loose a converter you need to go through the trans and get all that junk out and flush any cooling lines etc.


Quote:
Originally Posted by BBCMudbogger
I have a 396 in a full size mud truck that is pretty hot. I tore up one convertor after about 3 trips out racing and got another one (same company) and I think I am having the same problem after as many runs. When the convertor is new it will flash high as advertised (about 4500) but the next few times I have it out the truck will jump when put in gear and when I smack it the tach doesnt climb as rapidly as when the convertor is new and it feels sluggish like its too tight (this is the second one and I havent been out but about 6 times this year). This convertor is making me look like an ***. I guess my question is would there be something wrong in the th400 that could be causing it? The manf says it should be good for 800 hp and I am pretty sure it doesnt have that much...maybe 650 if I'm lucky
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-22-2008, 12:14 PM
Member
 
Last photo:
Join Date: Aug 2005
Location: Virginia
Posts: 875
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
If price is a gauge its a good one...lol....it is a transmission specialties....no debris in the tranny...........
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
torque convertors 82c10 Transmission - Rearend 1 07-06-2005 11:11 AM
Lock up TH350 Stall Convertors toooofastforu Transmission - Rearend 4 06-23-2004 05:13 AM
Tearing down a 74 L82 BT74 Engine 4 05-26-2004 01:31 PM
summit convertors Blob Transmission - Rearend 3 05-25-2004 04:40 PM
Am I Tearing Into A Fresh Rebuilt 351 Windsor? nightrain_rod Engine 7 12-08-2003 02:51 AM


All times are GMT -6. The time now is 06:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.