Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - tell me why
Thread: tell me why
View Single Post
  #8 (permalink)  
Old 06-24-2004, 09:44 AM
killerformula's Avatar
killerformula killerformula is offline
Hotrodders.com Moderator
 
Last wiki edit: Carburetor
Last journal entry: Clean up
Last photo:
Join Date: Oct 2003
Location: Northeast
Age: 34
Posts: 3,485
Wiki Edits: 3

Thanks: 13
Thanked 27 Times in 18 Posts
.060 350 block with a 400 crank is a 388, I'm building one right now (except this dufus from texas is draggin ***** on my intake ).

I don't think that's the problem, your motor should have plenty of power, before you rip it all apart do some checking and tuning. Use and advance timing light to see what your total timing is, and try adjusting the weights in your distributor. How big are your tires? Bigger tires are going to kill your launch. You should be making good power all the way up to the high 5000 range with that setup.

Did you inspect those heads? MANY problems have been reported with PTL heads. How is the idle on this thing? How much vacuum do you have? Give us some more info, do some checking.

Another thing you might check is your voltage to your coil. Make sure its getting an honest 12+ volts of juice all the way through the RPM band. If it starts dropping off, you might not be making the power.

Most importantly (re-reading your post) what kind of exhaust do u have on this thing? Exhaust is what ties the whole motor together, without it, your cam is working against you. You'll need headers (1 5/8 should work) and duals (2.5 inch is as far as you need to go).

K
Reply With Quote